1

I've got a book in which the relevant citation is really the editor, not the original author:

@book{butler_frankenstein_1998,
address = {Oxford ; New York},
series = {Oxford world's classics},
title = {Frankenstein, or, {The} modern {Prometheus}: the 1818 text},
isbn = {978-0-19-283366-2},
shorttitle = {Frankenstein, or, {The} modern {Prometheus}},
publisher = {Oxford University Press},
author = {Shelley, Mary Wollstonecraft},
editor = {Butler, Marilyn},
year = {1998},
keywords = {Frankenstein, Victor, Frankenstein's Monster, Horror tales, Monsters, Science fiction, Scientists}
}

(This was exported from Zotero)

So far all the bibliography styles I've tried (abbrv, acm, apalike, plain,...) generally don't even list the editor at all, let alone put her first.

Which bibliography style should I choose, or what modifications should I make, in order to get it to put the editor first, e.g.:

Butler, M. (ed.), M. W. Shelley, Frankenstein; or, The Modern Prometheus: the 1818 text (Oxford University Press, 1998).

or something similar?

I'm using latex & bibtex, but I'm happy to switch to natbib, biblatex, whatever else, and/or download style files. Just not sure what to do...

.

PS: Never used makebst before; intimidated, and anyway when I followed some instructions on How to make your personal LaTeX bibliography style I got:

$ latex makebst
This is pdfTeX, Version 3.14159265-2.6-1.40.17 (TeX Live 2016) (preloaded format=latex)
 restricted \write18 enabled.
entering extended mode
! I can't find file `makebst'.
<*> makebst

(Press Enter to retry, or Control-D to exit)
Please type another input file name: 
^D
$ sudo tlmgr install custom-bib
tlmgr install: package already present: custom-bib
$ ???
3

If you are willing to use biblatex, useauthor=false might be what you are looking for. You can add this to the options field in the bib entry

@book{butler_frankenstein_1998,
  address    = {Oxford and New York},
  series     = {Oxford world's classics},
  title      = {Frankenstein, or, {The} modern {Prometheus}},
  subtitle   = {the 1818 text},
  isbn       = {978-0-19-283366-2},
  publisher  = {Oxford University Press},
  author     = {Shelley, Mary Wollstonecraft},
  editor     = {Butler, Marilyn},
  year       = {1998},
  options    = {useauthor=false},
}

With style=authoryear that gives

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[style=authoryear]{biblatex}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{butler_frankenstein_1998,
  address    = {Oxford and New York},
  series     = {Oxford world's classics},
  title      = {Frankenstein, or, {The} modern {Prometheus}},
  subtitle   = {the 1818 text},
  isbn       = {978-0-19-283366-2},
  publisher  = {Oxford University Press},
  author     = {Shelley, Mary Wollstonecraft},
  editor     = {Butler, Marilyn},
  year       = {1998},
  options    = {useauthor=false},
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
\cite{butler_frankenstein_1998}.
\printbibliography
\end{document}

enter image description here

2
  • That's great, thanks @moewe! Took me a little while to get up to speed on biblatex, biber, etc, but now I'm reproducing your results, and along with adding "firstinits=true" in the \usepackage[]{biblatex} line, it gives me essentially what I need.
    – sh37211
    Dec 24 '17 at 22:31
  • @sh37211 Well, it only took you about half an hour, so I guess you were quick to pick up the most important bits and pieces. The option firstinits has been renamed to giveninits, so in newer versions of biblatex you want giveninits=true.
    – moewe
    Dec 24 '17 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.