4

I have the same problem as posted here: How to Install an Unavailable Document Class for LyX on Windows

I want to install the unavailable class LNCS in Lyx 2.2.2. I've tried those steps in the link but it still doesn't work. The Latex error message

File 'llncs.cls' not found

appears in Lyx when I run a template that uses LNCS class.

Please help!

6
  • Welcome to TeX SX! Did you refresh the F.N.D.B.?
    – Bernard
    Commented Dec 25, 2017 at 23:02
  • Alt+H C (Menu Help > Customization), but I would use a true LaTeX editor.
    – Fran
    Commented Dec 25, 2017 at 23:38
  • @Bernard Thanks, actually yes i've already refreshed FNDB and followed all the required steps in the link. Commented Dec 26, 2017 at 12:53
  • @HafidiYousra: AS I don't have LyX, I can give only general advice. I think you might try to compile your code from a standard editor like TeXmaker of TeX studio, and see if it works. You'll have a detailed .log file.
    – Bernard
    Commented Dec 26, 2017 at 13:04
  • 1
    Fine! Note that apckages which are not part of the distribution should nbe preferably installed in a local root, say TeXMFlocal, to be declared via MiKTeX Settings, root tab.
    – Bernard
    Commented Dec 26, 2017 at 13:35

4 Answers 4

5

I found the problem,

A little clarification for those who want to install a class in LyX. Please follow these steps that are mentioned in the previous link:

Step 0:

Quit LyX

Step 1:

Download llncs2e.zip, which contains llncs.cls and llncsdoc.sty. I just googled for a download link and got mine from here.

Step 2:

Copy those files to the folder ...\MiKTeX 2.7\tex\latex\lncs, where ...\MiKTeX 2.7 is the folder in which MiKTeX is installed. On some systems, copy to ... \MiKTeX 2.7\texmf\latex\lncs. The lncs folder will probably need to be created.

Mine was in C:\Program Files (x86)\MiKTeX 2.9\tex\latex, where I had to create the lncs folder (which requires admin privilege escalation). I extracted llncs.cls and llncsdoc.sty to this folder.

Step 3:

Run

texhash

from the command line.

Step 4:

Run MiKTeX Settings. Press "Refresh FNDB" under General. Then, possibly, "Update Formats".

Step 5:

Open LyX and select Tools -> Reconfigure

Very straightforward


But be sure to put the llncs.cls and llncsdoc.style files in:

C:\Users\YOURUSERNAME\AppData\Roaming\MiKTeX\2.9\tex\latex\lncs

PS. Create the folder lncs if it doesn't exist.

0

If you are using TexLive, put the llncs.cls in the following path:

TEXLIVE_ROOT_PATH/YEAR/texmf-dist/tex/latex/llncs2e

The YEAR is 2018 if you are using TexLive 2018.

Run texhash.

Open Lyx and 'Tools' -> 'Reconfigure'.

Now in 'Document' -> 'Settings' -> 'Document Class', you should be able to see Lecture Notes in Comp. Science (LNCS) in the drop-down list.

0

This problem happened for me when I downloaded the Springer LaTeX template and tried importing the tex file into Lyx. I got this error: "The selected document class Lecture Notes in Comp. Science (LNCS) requires external files that are not available. The document class cannot be compiled until the following prerequisites are installed: llncs.cls. See section 3.1.2.2 (Class Availability) of the User's Guide for more information."

enter image description here

So I looked opened the "Help" menu of the Lyx editor to view the User guide and did some searching to find this, this, this, this, this and this, but nothing worked.

The solution:
I finally noticed that on opening one guy's tex file, the error didn't show up. Comparing the difference, I found the reason.

Springer's default tex file has this line:

\documentclass[runningheads]{llncs}

It should actually be this:

\documentclass[runningheads,a4paper]{llncs}

And that's it. The error didn't show up anymore.

0

I found that if I placed the files llncs.cls and splncs04.bst in the same folder as my .lyx file, the document would compile and display correctly with LyX's pdflatex option.

These files can be obtained from the instructions for authors page provided by Springer in the LaTeX2e Proceedings Templates (zip)

LyX Version 2.3.5.2
(Thursday, June 25, 2020)

Library directory: C:\Program Files (x86)\LyX 2.3\Resources\
User directory: ~\AppData\Roaming\LyX2.3\
Qt Version (run-time): 5.12.5
Qt Version (compile-time): 5.12.5

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .