4

To activate the ebook package, one has to put \usepackage{ebook} in the preamble, and \ebook in the document. If both are activated, \mkbibbold stops working while \textbf works fine. Why is that?

I use XeLaTeX -> Biber-> XeLaTeX.

WME

\documentclass{report}
%\usepackage{ebook}
\usepackage[style=authortitle,url=false]{biblatex}
\addbibresource{Qu.bib}

\renewcommand*{\newunitpunct}{\addspace\bibrangedash\space}
\DeclareFieldFormat*{title}{\mkbibbold{#1}}

\begin{document}
%\ebook
\textbf{Bold text} \textit{Italic text}
\nocite{*}
\printbibliography[heading=subbibliography,keyword=Projective geometry,title=Hình học xạ ảnh]
\end{document} 

Results

Log file

If \renewcommand{\bibfont}{\textnormal} is used, then the heading is not large anymore

FYI: How to have a bibliography style like Google Scholar?

4
  • 1
    Don't use the package with xelatex (actually don't use it at all, it seems to have only a vage idea about how to change the font setup and uses a more or less random set of commands). Dec 26 '17 at 11:39
  • unfortunately only XeLaTeX can produce pretty result
    – Ooker
    Dec 26 '17 at 11:57
  • 2
    I didn't say that you shouldn't use xelatex but don't use the package ebook -- it is not good. Dec 26 '17 at 12:51
5

The package ebook does not change fonts in a good way. In particular, the result is a different set of fonts is being used in the bibliography. To work around this you can either compile with pdflatex or use

\renewcommand{\bibfont}{\textnormal}

Sample output

\documentclass{report}

\usepackage{ebook}
\usepackage[style=authortitle,url=false]{biblatex}
\addbibresource{Qu.bib}

\renewcommand*{\newunitpunct}{\addspace\bibrangedash\space}
\DeclareFieldFormat*{title}{\mkbibbold{#1}}
\renewcommand{\bibfont}{\textnormal}

\begin{document}
\ebook
\textbf{Bold text} \textit{Italic text}
\nocite{*}
\printbibliography
\end{document}

with Qu.bib

@Book{Douglas:Moebius,
  author =   {Douglas, Arnold},
  title =    {Moebius transform},
  year =     2000
}
4
  • Thanks. I'm trying to use hyperref to avoid the border wrapping the links. The ebook package has option clash with it, even though it is only loaded once. Do you know how to fix?
    – Ooker
    Dec 26 '17 at 11:56
  • Use \hypesetup to adjust options to hyperref. Dec 26 '17 at 12:26
  • \hypersetup{colorlinks = false,linkbordercolor = {0 0 0}} doesn't work, while linkbordercolor={white} is not support. I also notice that after using \renewcommand the heading is not large anymore. Do you have any ideas?
    – Ooker
    Dec 26 '17 at 12:49
  • 1
    \hypsetup{hidelinks=true}. The heading does not change size for me, but the bib text is larger; can use e.g. \renewcommand{\bibsetup}{\small} to get that text smaller again. Dec 26 '17 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.