3

My usual method of loading fonts for xelatex gives unsatisfactory results when I choose Arno Pro as main text font and Cambria Math as math font, in particular, inline math symbols are larger then surrounding text. Here is MWE and result of its compilation with xelatex.

\documentclass{article}
\usepackage{ifluatex,ifxetex}
\ifnum 0\ifxetex 1\fi\ifluatex 1\fi>0
    \usepackage{fontspec}
    \setmainfont[Numbers={Proportional}]{Arno Pro}
    \usepackage[math-style=ISO,bold-style=ISO]{unicode-math}
    \setmathfont{Cambria Math}
\else
    \usepackage[T1]{fontenc}
    \usepackage[utf8]{inputenc}
\fi

\begin{document}
If we assume that the radius of the waist at the focus of the 
laser pulse is $a=50\,\mu\textnormal{m}$, and its length is 
$L=1\,\textnormal{cm}$, the electron density is estimated at 
the level of $n_{e} = 1.6{\times}10^{19}\,\textnormal{cm}^{-3}$.
\end{document}

enter image description here

Is there a simple way to correct this issue?

  • 6
    \setmathfont[Scale=MatchLowercase]{Cambria Math} – egreg Dec 27 '17 at 7:12
  • @egreg: Thanks. I forgot about this option. – Igor Kotelnikov Dec 27 '17 at 7:28
  • @egreg Do you want to post an answer? – TeXnician Dec 27 '17 at 10:33
1

\setmathfont can receive the same font loading options as \setmainfont and similar commands, so one among

\setmathfont[Scale=MatchLowercase]{Cambria Math}
\setmathfont[Scale=MatchUppercase]{Cambria Math}
\setmathfont[Scale=<factor>]{Cambria Math}

will do. Which one depends on the main font and its features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.