3

My code looks as follows:

\documentclass[12pt,a4paper]{report}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[activate={true,nocompatibility},final,tracking=true,kerning=true,spacing=true,factor=1100,stretch=10,shrink=10]{microtype}
\usepackage{ae,aecompl}
\begin{document}
    \section{AVAW Wo}
    AVAW Wo
\end{document}

I don’t know what is wrong. I have set the option kerning=true – and it still does not work.

enter image description here

  • 1
    Remove the calls to ae and aecompl – egreg Dec 27 '17 at 21:12
  • 1
    Then install the cm-super package. – Ulrike Fischer Dec 27 '17 at 21:31
  • 1
    @Nemgathos Are you running MiKTeX, by chance? – egreg Dec 27 '17 at 21:38
  • 1
    what do you mean by "doesn't work"? -- there is kerning in your example (with or without microtype); I also guess there's a misunderstanding about the kerning option, check the microtype manual – Robert Dec 28 '17 at 1:10
  • 2
    I can only repeat myself: (1) there is kerning in your example (add \tracingoutput1 \showboxdepth100 \showboxbreadth100 to your example, and you will see the \kern directives in the log file). (2) the kerning option of microtype does not affect normal kerning, which is built into the font. – Robert Dec 29 '17 at 3:57
0

(too long for a comment, hence posted as an answer)

I would like to question your claim that the kerning option of the microtype package "doesn't work". Specifically, compare the following two screenshots: the upper was compiled with pdfLaTeX, and the lower was compiled with LuaLaTeX. (Recall that the kerning and spacing options currently aren't enabled under LuaLaTeX.) (Aside: I use MacTeX2017, on a MacBook Pro that runs MacOS X 10.13.2 "High Sierra".) To my eye at least, microtype does apply additional kerning under pdfLaTeX.

enter image description here

enter image description here

(The framelines are produced by the showframe option of the geometry package.)

  • I can understand that this example might not be that good. But what do you think about this? I have even had something like this. – Nemgathos Dec 28 '17 at 9:46
0

I have finally found a solution that works for me! Ulrike Fischer gave me a good hint in a comment here.

My preamble now looks as follows:

\documentclass[12pt,a4paper]{report}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[activate={true,nocompatibility},final,tracking=false,kerning=true,spacing=false,factor=1100,stretch=10,shrink=10]{microtype}
\DisableLigatures[f]{encoding = T1}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.