1

I'm trying to compile a document using either XeLaTeX/LuaLateX and biblatex/biber, but I'm having trouble with a bibliographic entry that contains non-english characters. My MWE is:

% -*- program: xelatex -*-
\documentclass[12pt,twoside,headings=big,open=right]{scrreprt}
\usepackage{scrhack,graphicx,subcaption,nomencl,setspace,fontspec,csquotes,microtype,xcolor,tocbibind,xspace,floatrow}
\defaultfontfeatures{Ligatures=TeX}

\usepackage[a4paper,width=150mm,top=25mm,bottom=25mm,bindingoffset=6mm]{geometry}
\usepackage[british]{babel}

\usepackage[style=authoryear-comp, punctfont, sorting=ynt, eprint=false, giveninits=true, uniquename=init, doi=false, url=false, isbn=false, backend=biber, maxbibnames=99, maxcitenames=2, uniquelist=false, backref=true]{biblatex}
\addbibresource{library.bib}

\setmainfont{Minion Pro}
\setsansfont{Myriad Pro}

\begin{document}
\autocite{Cetinkayadonmez1999}
\autocite{Imhoff1984}
\printbibliography
\end{document}

And my .bib file is:

@article{Cetinkayadonmez1999,
abstract = {Abstract},
author = {{{\c{C}}eti̇nkaya D{\"{o}}nmez}, G{\"{o}}n{\"{u}}l and {\"{O}}zt{\"{u}}rk, Ayten and {\c{C}}akmak{\c{c}}i, L{\"{u}}tf{\"{u}}},
journal = {Turkish Journal of Biology},
pages = {457--563},
title = {{Properties of the Rhodopseudomonas palustris Strains Isolated From an Alkaline Lake in Turkey | Growth Medium | Bacteria}},
volume = {23},
year = {1999}
}
@article{Imhoff1984,
abstract = {Abstract},
author = {Imhoff, J. F. and Truper, H. G. and Pfennig, N.},
doi = {10.1099/00207713-34-3-340},
issn = {0020-7713},
journal = {International Journal of Systematic Bacteriology},
month = {jul},
number = {3},
pages = {340--343},
title = {{Rearrangement of the Species and Genera of the Phototrophic "Purple Nonsulfur Bacteria"}},
volume = {34},
year = {1984}
}

The 'Imhoff1984' citation works perfectly, if I comment out the 'Cetinkayadonmez1999' citation.

I read this question, and this question; and tried changing the author line from:

author = {{{\c{C}}eti̇nkaya D{\"{o}}nmez}, G{\"{o}}n{\"{u}}l and {\"{O}}zt{\"{u}}rk, Ayten and {\c{C}}akmak{\c{c}}i, L{\"{u}}tf{\"{u}}},

to:

author = {{\cC}etinkaya D{\"o}nmez, G{\"o}n{\"u}l and {\"O}zt{\"u}rk, Ayten and {\cC}akmak{\cc}i, L{\"u}tf{\"u}},

But this hasn't helped.

I've tried compiling with both LuaLaTeX and XeLaTeX, but neither work with the 'Cetinkayadonmez1999' citation (they both work with just the other citation).

The .bib file is automatically generated by Mendeley, so if it's possible to find a solution that doesn't involve manually fixing every entry, that would be wonderful (my full file has hundreds of entries).

I'm not very accomplished at interpreting .log files, but I'm guessing that the relevant section is:

Package biblatex Info: XeTeX detected.
(biblatex)             Assuming input encoding 'utf8'.
Package biblatex Info: Automatic encoding selection.
(biblatex)             Assuming data encoding 'utf8'.
\openout4 = `main.bcf'.

Package biblatex Info: Trying to load bibliographic data...
Package biblatex Info: ... file 'main.bbl' found.


/MWE2/main.bbl)
Package biblatex Info: Reference section=0 on input line 15.
Package biblatex Info: Reference segment=0 on input line 15.
! Undefined control sequence.
\namepartfamily ->{\cC 
                       }etinkaya\bibnamedelima D{ö}nmez
l.16 \autocite{Cetinkayadonmez1999}

The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

[1

] [2


]
Package microtype Info: Loading generic protrusion settings for font family
(microtype)             `MyriadPro' (encoding: TU).
(microtype)             For optimal results, create family-specific settings.
(microtype)             See the microtype manual for details.
! Undefined control sequence.
\namepartfamily ->{\cC 
                       }etinkaya\bibnamedelima D{ö}nmez
l.19 \end
         {document}
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

! Undefined control sequence.
\namepartfamily ->{\cC 
                       }akmak{\cc }i
l.19 \end
         {document}
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

! Undefined control sequence.
\namepartfamily ->{\cC }akmak{\cc 
                                  }i
l.19 \end
         {document}
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

[3]

/MWE2/main.aux)
Package logreq Info: Writing requests to 'main.run.xml'.
\openout1 = `main.run.xml'.

 )
  • \cC sound like a very strange recommendation. You should turn this into \c{C} again. Also remove the .bbl file when recompiling. As you are using a unicode-aware engine you might want to input the special characters directly instead of escaping them. – TeXnician Jan 1 '18 at 16:12
  • @TeXnician, thank-you, using {\c{C}} worked perfectly. – beanstalker Jan 1 '18 at 16:37
  • Using {\"{o}} also seems to work just as well as using {\"o}, so I'm confused as to what was wrong with the original Mendeley file. It looks like it inserted an extra { somewhere, but when i regenerate the file it seems to have disappeared, so I'm not sure what happened. – beanstalker Jan 1 '18 at 16:39
4

The error is in

author = {{{\c{C}}eti̇nkaya D{\"{o}}nmez}, G{\"{o}}n{\"{u}}l and {\"{O}}zt{\"{u}}rk, Ayten and {\c{C}}akmak{\c{c}}i, L{\"{u}}tf{\"{u}}},

and precisely in the additional braces around the double family name.

If you change this into

author = {{\c{C}}etinkaya D{\"{o}}nmez, G{\"{o}}n{\"{u}}l and {\"{O}}zt{\"{u}}rk, Ayten and {\c{C}}akmak{\c{c}}i, L{\"{u}}tf{\"{u}}},

you'll have no problems (also should probably be i).

On the other hand, you can safely type in the names in the normal way they're written

author = {Çetinkaya Dönmez, Gönül and Öztürk, Ayten and Çakmakçi, Lütfü},

enter image description here

Unfortunately, Mendeley is known to do strange things.

  • Thanks @egreg that was it. Was definitely a Mendeley problem. I tried regenerating the file, and this time it escaped everything correctly, without the extra {}. No idea why. I've tried turning off the option to escape LaTeX characters in Mendeley, so as to avoid escaping non-english characters, but this makes things worse because then it stops escaping other characters such as &... – beanstalker Jan 1 '18 at 16:44
  • @egreg: Sorry, I focused on the first two code snippets and didn't see the last one. I'll remove my comment. I guess it was a side-effect of the new year… B.t.w., happy new year! – Bernard Jan 1 '18 at 23:22
  • @Bernard Too much champagne during the celebrations? ;-) Happy new year! – egreg Jan 1 '18 at 23:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.