This question already has an answer here:

I want to use the Fourier package for my personal LaTeX class but when MiKTeX wants to install it, it did not succeed... When compiling my minimal document, MiKTeX echoes me an error message (strangely only in the log file):

!pdfTeX error: pdflatex (file futr8r): Font futr8r at 604 not found
 ==> Fatal error occurred, no output PDF file produced!

How can I solve this problem?


My example:

\author{Nicolas T}



This is a test.

An other warning message: The warning message

Thanks for help!

marked as duplicate by egreg, TeXnician, Stefan Pinnow, user121799, Phelype Oleinik Oct 30 '18 at 16:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @NicolasT Here, with the full version of MikTeX, there is no problem. – AndréC Jan 2 '18 at 12:26
  • 3
    The compiler tries to make bitmap fonts, which means the type 1 fonts databases have not been updated. Running updmap --admin should do the trick. – Bernard Jan 2 '18 at 12:51

As @Bernard said, I tried to enter the updmap --admin command in CMD in Windows but it did not succeeded. I looked for the manual and I found the option --force. It is this one we have to enter to make that work!

Thanks a lot for your answer!

So, in conclusion, the command to enter to solve this problem is:

updmap --admin --force
  • 2
    I have some doubts. --force should normally only affect the xelatex font cache. Normally when updmap --admin doesn't work in miktex it means that you have user map files hiding the admin files and should use updmap without the --admin switch to update them. – Ulrike Fischer Jan 3 '18 at 9:27
  • I have solve my problem by this way... That is strange I know... I also tried with no --admin but anything happened. So I tried with the --force option and I succeeded. – Nicolas T. Jan 3 '18 at 9:39
  • If you ran upmap without -admin in between then you updated the user map files and corrected the problem (there is no output when you run the command, it is silent unless you use the --verbose switch). – Ulrike Fischer Jan 3 '18 at 9:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.