I am trying to write: "(e.g. Surname, 2018)" using apacite package.

I have tried (e.g. \cite{surname2018}}) (too many brackets), \cite{surname2018} (does not have e.g.) , and (e.g. \citeA{surname2018}} but it still does not work.

What should I do in this case?

  • 1
    Welcome! Does (e.g.~\citet{surname2018} ) work?
    – user121799
    Jan 2 '18 at 23:53
  • 1
    In natbib package \citep has two optional parameters for prefix and postfix, but this won't help you, probably. Jan 2 '18 at 23:55
  • Thank you, marmot! I tried that and it comes out as an error (using citet).
    – MPS
    Jan 3 '18 at 0:02

The apacite package supports two sorts of citation commands, its own version, or the natbib versions (loaded with the natbibapa package option.)

The citation commands support both a pre-note and a post-note. The basic syntax is:


where \cite gives you (pre-note Author, Year, post-note), \citeA gives you pre-note Author (Year, post-note).

So to get your example, you would use:


If you are using the natbibapa option, the command syntax is slightly different:


yields pre-note Author (year,post-note) while


yields (pre-note Author, Year, post-note).

Since square brackets are used to delimit both the pre-note and the post-note, you need to provide an empty post-note to get a pre-note only. So your example would be:


You can find the full set of citation commands in the apacite documentation, or for a quick summary see: What is the relationship between natbib, apacite package, and apa document class?.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.