4

I am trying to compile a simple latex document:

\documentclass{report}
\usepackage{inconsolata}
\begin{document}
  \normalfont\ttfamily
  Some text
\end{document}

But my output looks like this:

"Some text" written with the default normal font

Rather than the expected:

"Some text" written the way I'd expect

Removing the \usepackage{inconsolata} gives me the default \ttfamily font but I'd like to be able to use inconsolas.

I am using the MiKTeX distribution on Windows and while compiling, using Lualatex, I get the following output:

This is LuaTeX, Version 1.06.2 (MiKTeX 2.9.6530 64-bit)
 restricted system commands enabled.
(./testing_tt.tex
LaTeX2e <2017-04-15>
(using cache: C:/Users/XYZ/AppData/Local/MiKTeX/2.9/luatex-cache/generic)
luaotfload | main : initialization completed in 0.493 seconds
Babel <3.15> and hyphenation patterns for 1 language(s) loaded.
("C:/Program Files/MiKTeX 2.9/tex/latex/base/report.cls"
Document Class: report 2014/09/29 v1.4h Standard LaTeX document class
("C:/Program Files/MiKTeX 2.9/tex/latex/base/size10.clo"(load luc: C:/Users/XYZ/AppData/Local/MiKTeX/2.9/luatex-cache/generic/fonts/otl/lmroman10-regular.lu
c))) ("C:/Program Files/MiKTeX 2.9/tex/latex/inconsolata/inconsolata.sty"
`inconsolata-zi4' v1.112, 2017/01/04 Text macros for Inconsolata (msharpe)
("C:/Program Files/MiKTeX 2.9/tex/latex/base/textcomp.sty"
("C:/Program Files/MiKTeX 2.9/tex/latex/base/ts1enc.def"))
("C:/Program Files/MiKTeX 2.9/tex/latex/xkeyval/xkeyval.sty"
("C:/Program Files/MiKTeX 2.9/tex/generic/xkeyval/xkeyval.tex"
("C:/Program Files/MiKTeX 2.9/tex/generic/xkeyval/xkvutils.tex"
("C:/Program Files/MiKTeX 2.9/tex/generic/xkeyval/keyval.tex")))))
(./testing_tt.aux) ("C:/Program Files/MiKTeX 2.9/tex/latex/base/ts1cmr.fd")
("C:/Program Files/MiKTeX 2.9/tex/latex/upquote/upquote.sty")

LaTeX Font Warning: Font shape `TU/zi4/m/n' undefined
(Font)              using `TU/lmr/m/n' instead on input line 4.

[1{C:/Users/XYZ/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map}]
(./testing_tt.aux)

LaTeX Font Warning: Some font shapes were not available, defaults substituted.

)
 355 words of node memory still in use:
   2 hlist, 1 vlist, 1 rule, 2 glue, 3 attribute, 45 glue_spec, 3 attribute_lis
t, 1 write nodes
   avail lists: 2:15,3:2,4:1,5:21,6:1,7:22,8:1,9:6
<c:/program files/miktex 2.9/fonts/opentype/public/lm/lmroman10-regular.otf>
Output written on testing_tt.pdf (1 page, 3672 bytes).
Transcript written on testing_tt.log.

I realise that I get a warning about a font not being available (presumably inconsolata), what I don't understand is why.

the miktex-makepk.log shows:

2018-01-03 01:29:03,274+0100 INFO  miktex-makepk - starting with command line: miktex-makepk --enable-installer --verbose ot1-zi4r-0 600 600 magstep(0.0)
2018-01-03 01:29:03,276+0100 INFO  makepk - Trying to make PK font ot1-zi4r-0 at 600 DPI...
2018-01-03 01:29:03,286+0100 INFO  makepk - The METFAONT mode is: ljfour
2018-01-03 01:29:03,293+0100 INFO  makepk - Running miktex-makemf.exe...
2018-01-03 01:29:03,296+0100 INFO  makepk - running: miktex-makemf.exe --verbose ot1-zi4r-0
2018-01-03 01:29:03,600+0100 INFO  makepk - Running miktex-ttf2pk.exe...
2018-01-03 01:29:03,604+0100 INFO  makepk - running: miktex-ttf2pk.exe -q -t ot1-zi4r-0
2018-01-03 01:29:03,899+0100 FATAL miktex-makepk - PK font ot1-zi4r-0 could not be created.

I have:

  • Uninstalled and reinstalled the inconsolata package through the MiKTeX packet manager (as admin)
  • Made sure the the inconsolata style files are present (from what I understand this message 'inconsolata-zi4' v1.112, 2017/01/04 Text macros for Inconsolata (msharpe) indicates that it is found as well)
  • Verified the *.pfb font files are present in: C:\Program Files\MiKTeX 2.9\fonts\type1\public\inconsolata

I am not sure where else to look, perhaps someone else knows what might be the issue?

  • I get the correct output with pdflatex, however – user31729 Jan 3 '18 at 0:27
  • I get the following using pdflatex: `PK font ot1-zi4r-0 could not be created.´ I recognize zi4r to be connected to inconsolata – Christian Eriksson Jan 3 '18 at 0:30
  • I am no lualatex user, but if I remember correctly it's not useful to load font packages that are meant for pdflatex/latex; that's why fontspec should be used (if I am right) – user31729 Jan 3 '18 at 0:38
  • I didn't realize that the inconsolata package was meant for pdflatex/latex only. Is that what you are saying? – Christian Eriksson Jan 3 '18 at 0:43
  • 1
    I’m no lualatex user either, but if I recollect correctly, using lualatex entails switching to the TU encoding by default; and, indeed, it seems that no utzi4.fd file exists (while both ot1zi4.fd and t1zi4.fd do exist). – GuM Jan 3 '18 at 0:58
4

If you use fontspec,

\documentclass{report}
\usepackage{fontspec}
\setmonofont{Inconsolatazi4}

\begin{document}

\ttfamily Some text

\end{document}

enter image description here

  • Does it require inconsolata being installed as a regular font usable by other programs or just the inconsolata package? – thymaro Jan 3 '18 at 22:15
  • 1
    @thymaro With LuaLaTeX it's only necessary the OT font is installed in TeX Live or MiKTeX. Both distributions provide it. With XeLaTeX you need the OT font is visible as a system font. – egreg Jan 3 '18 at 22:32
1

Since you appear to be using LuaLaTeX, you shouldn't load the inconsolata package directly. Instead, use the following instructions:

\usepackage{fontspec}
\setmonofont{inconsolata}

This setup loads the OpenType font file Inconsolatazi4-Regular.otf. And, if you use the combination of \ttfamily and \bfseries, the OpenType font file Inconsolatazi4-Bold.otf will be loaded as well -- automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.