1

My old laptop died, and I need to rebuild my TeX-system. The new setup:

Windows 10, MikTeX 2.9, WinEdt10.2

In my old system I somehow managed to make WinEdt behave in the following IMHO desirable way. May be not your preferences, but this leads to an ideal workflow for me:

  1. When I click a .TeX file, WinEdt opens it and starts with no other previously opened files (those are a pain in the hindquarters if you ask me, because the list just keeps growing...)
  2. When I click a .prj file it opens the master file and the other files I have specifically added to that project (by creating them when the project is open). And no other files.

The trouble is that I don't have a clue how I managed it last time. I asked a lot of people (even the friendly people at WinEdt), and somehow I managed. (You guessed, those config files are only on the hard drive of the dead laptop.) What I thought was sensible guessing was not enough :-)

I just ran the WinEdt Configuration Wizard, and now it works somehow (.tex and .prj filetypes are associated to WinEdt). But the above problems persist because I really don't know which options manage this behavior and the FAQ is mostly Greek to me. Problems:

  • When I click the icon of a project file, say, LectureNotes.prj, it also opens the irrelevant *.prj file rather than the LaTeX-source files as I expected/wanted.
  • If I follow the instructions here, and include the lines

    [PROJECT_MANAGER*]

    RESTORE_OPENED_FILES=0

then what happens is that only the .prj file is opened. Not even the master file is anywhere to be seen.

  • Suspecting that something with .prj -files had changed since WinEdt7 I recreated the project by setting a master file, and the help files (chapter1.tex, chapter2.tex etc). Saved it as a project. No cigar! This time the .prj file also had lines with name of other recently opened filed (such as HomeworkWk1.tex) unrelated to the lecture notes project!

How do I achieve this? Is there a WinEdt-options for dummies somewhere in the interwebs :-)


A problem a user like me has with WinEdt is that it tries to do so much. I probably only ever use a tiny fraction of the menu items, and it kinda overwhelms my feeble brain. I do realize that not everybody wants to just use tex->dvi->ps->pdf flow with only good ole LaTeX, so no problem there. It is just me.


When these problems are solved (I'm confident that some friendly person her knows how to), I will start worrying about character sets of files. Last time when I ported source made in Windows XP into Windows 7 I had serious difficulties getting with the different character sets (ASCII, UTF-8, whatnot), IIRC some of those issues were never fully solved, and I need to do strange things to get scandic letters "äöåÄÖÅ" to show correctly. Wish me luck! If I run into problems I will ask :-)


Edit: I tried tinkering in the Options Interface. No light bulbs for me :-(. More annoyingly, as a consequence of my tinkering some data about the ini-files were tagged into the .prj-file. WTF. Why should a prj-file have any information not related to the TeX-files of the project??


Edit(2): I asked Alex@winedt.com. Their diagnosis was that something had went wrong when I tried to run the Configuration Wizard. I think I ran with admin privileges, but I tried it again, and this time I added, as per Alex's instructions, "-V " in the command switch box. This cured the problem with prj-files as well as the problem of opening previous files.

Alex further adviced

  • against changing the default

    RESTORE_OPENED_FILES=1

    for this purpose, and recommended using the command switch "-V ". Arzigoglu's answer gave the same suggestion so I accepted that to let this thread drift into the background. I couldn't figure out how to do that change with regedit, but I guess running the configuration wizard with admin privileges amounted to the same.

  • not to open any ini-files while working with a project. Close the project first, and then tinker. That way those files won't leave any marks in the prj-file.
  • For accented letters, using DejaVu Sans as the default font in WinEdt is quite fine. – Bernard Jan 3 '18 at 19:50
  • @Bernard IIRC the problems I had were more like: getting a macro text "Määritelmä" (Finnish for "Definition") defined in a master file using UTF-8 to show up correctly when the macro is used in a file containing the source for chapter 1, using Codepage 850 (IIRC). As well as the chapter titles from files with various character coding to be come up correctly in the table of contents. I'm not 100% I will try that later. First I need to learn how to manage the list of files to be opened when starting WinEdt. – Jyrki Lahtonen Jan 3 '18 at 20:01
  • I downloaded the QuickGuide from WinEdt website. Can't say I found anything remotely useful :-( – Jyrki Lahtonen Jan 3 '18 at 22:55
  • Did you ask the author of WinEdt (alex@winedt.com). In general, he's very responsive. – Bernard Jan 3 '18 at 23:02
  • I just sent e-mail to support@winedt.com. Yes, my experience is also that they are quite helpful - even when I didn't "deserve" it :-) – Jyrki Lahtonen Jan 3 '18 at 23:07
3

Try this.

  1. Open the Windows registry editor (Win+R -> regedit).

  2. On the HKEY_CLASSES_ROOT find the WinEdt.TeX key.

  3. Go to subkey WinEdt.tex\shell\open\command

  4. On the predefined value, change something like

    "C:\Program Files\WinEdt Team\WinEdt 10\WinEdt.exe" "%1"

    to

    "C:\Program Files\WinEdt Team\WinEdt 10\WinEdt.exe" -V "%1"

    (note the addition of -V switch)

That should be enough to achieve what you want.


Note that the right registry key might be HKEY_CURRENT_USER\Software\Classes\WinEdt.TeX if you don't have admin privileges.


Source: WinEdt manual index -> Command Line Switches

-V

Starts WinEdt in "Virgin Mode": the last project is not automatically opened and no files are immediately restored.

  • I couldn't follow these instructions, but thanks anyway. I should have figured out a way to start regedit with admin privileges I guess. – Jyrki Lahtonen Jan 4 '18 at 20:50
2

What Arzigoglu wrote in her/his answer is perfectly right.

In fact -V is the right command line switch to start WinEdt in "virgin mode".

However, instead of modifying the Windows registry, this can be done directly from within WinEdt.

Open the Configuration Wizard dialog from the Options menu and select the "Filetype Associations" tab.

Depending on your privileges, choose "Modify filetypes associations" for All Users or the Current User. The following dialog appears:

enter image description here

Simply add -V in the "Command Switches" field for all the filetypes you want and then press OK.

  • This is what alex@winedt.com told me to do, too. I think it is important to have started the Configuration Wizard with admin privileges, but I'm not 100%. Because currently it works, I'm not gonna test anything else now :-). Thanks anyway. This is useful for future readers of the question. – Jyrki Lahtonen Jan 5 '18 at 7:21
  • @JyrkiLahtonen Yes, that's why I've posted the answer. – karlkoeller Jan 5 '18 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.