2

I feel this is a very, very silly question, but when I open a .tex file with TeXShop it compiles it immediately, shows the preview, and doesn't show the source code. I've tried to get back to the source code with CMD-1 but it didn't help. How should I get back to the source?

  • The standard way to switch between Preview and Source Windows in TeXShop is Cmd-1. I’m not sure what is happening on your system. Are you using a distributed source (I.e., have a root file which “includes” other files)? – Herb Schulz Jan 4 '18 at 21:15
  • Wait... do you have TeXShop set up to use an external Editor? Under the Source tab in TeXShop->Preferences do you have Configure for External Editor in the Startup section checked? – Herb Schulz Jan 4 '18 at 22:11
  • @HerbSchulz that was it, thanks! Consider turning your comment into an answer so I can accept it. – lindelof Jan 5 '18 at 14:01
2

Do you have TeXShop set up to use an external Editor? Under the Source tab in TeXShop->Preferences do you have Configure for External Editor in the Startup section checked? If so, uncheck that box, save the preferences and restart TeXShop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.