4

This is my preamble:

\documentclass[a5paper, DIV=classic, 12pt]{scrbook}
\usepackage{xltxtra,fontspec,graphicx,xunicode,color,lettrine}
\setmainfont[Mapping=tex-text, Ligatures={Rare}, Numbers=OldStyle]{ibarraReal}
\usepackage[spanish]{babel}

The problem is in the a5paper option, because I get the following

enter image description here

So, how can I fix the problem with margins?

4
  • 1
    Hm that is never 12 pt on a A5 paper. I think you are putting the A5 paper at the upper left corner of a bigger paper somehow.
    – jonalv
    Jan 12, 2012 at 15:53
  • 2
    This is A5 superimposed on A4; add \usepackage[pass]{geometry} to the preamble, as scrbook doesn't inform xdvipdfmx about the paper size.
    – egreg
    Jan 12, 2012 at 15:55
  • 1
    Just for what is worth: it's not really a minimal example, nor is it a complete example. (Also you could have mentioned you were using XeLaTeX.
    – user10274
    Jan 12, 2012 at 16:04
  • @Marc I think the example is excellent. Thank you for your review. ;)
    – Gastón
    Jan 12, 2012 at 17:04

1 Answer 1

7

Simply add the pagesize option:

\documentclass[a5paper, DIV=classic, 12pt, pagesize]{scrbook}

It's actually an option for typearea. If you set this option, the class sets PDF page dimensions if used with pdfLaTeX, and uses a DVI \special for the paper size if it runs in DVI mode.

It can be forced specifying the output driver, such as pagesize=pdftex, pagesize=dvips, or pagesize=dvipdfmx, however I recommend to use auto or no value, which means the same.

1
  • I swear I searched for the answer in Koma doc, but didn't find it :) Thank you!
    – Gastón
    Jan 12, 2012 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.