2

I think this is new, because this is not the first time I've used Texstudio with aa.cls, but now when compiling this:

\documentclass{aa}

\title{We're great}
\abstract{We insist}
\author{a \and b}

\begin{document}
    \maketitle

    \section{Introduction}
        Hello world!
\end{document}

I'm using the latest class provided by Astronomy and Astrophysics (aanda, aa.cls which can be downloaded directly from here). The internal pdf viewer is just showing a rectangle where the header should be (in the proper place) and a small circle in the top right, presumably from the copyright symbol that's supposed to be there.

Here are the screenshots of the internal and external (Evince) viewers: internal external

When compiling the internal viewer does mark where the text should appear, but you see the result below. I would rather stick with it as it's synced to the line I'm marking. oddly commenting out %\RequirePackage[T1]{fontenc} in the aa.cls fixed this issue. I rather not do this, so what am I missing?

If relevant the specs are Debian 9, Tex Live package 2016.20170123-5. Changing the document class to article will remove this problem, and the viewer will work nicely as usual.

Some testing

Beyond the system package, I tried installing version 12 from the site, both qt4 and qt5, and version 11.2 (compiled from source). All show same behavior. I ran texstudio from the console to see if something is happening that I'm missing and I got a ton of:

Error (257): Missing or bad Type3 CharProc entry

This only happens for this document class (at least it doesn't happen for article). I found out this is thrown by the poppler library, but I don't know what would cause it. The result of pdffonts is:

name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
[none]                               Type 3            Custom           yes no  no       4  0
[none]                               Type 3            Custom           yes no  no       5  0
WCJTWI+CMSY10                        Type 1            Builtin          yes yes no       6  0
[none]                               Type 3            Custom           yes no  no       7  0
[none]                               Type 3            Custom           yes no  no       8  0
[none]                               Type 3            Custom           yes no  no       9  0
[none]                               Type 3            Custom           yes no  no      10  0
[none]                               Type 3            Custom           yes no  no      11  0
2

I have a virtual machine running Debian 9.

After installing also cm-super with Synaptic, here's a screen shot. In the terminal window you can see the output of pdffonts before and after this update.

enter image description here

Some more information: TeXStudio is version 2.11.2 (installed this morning; uses Qt version 5.7.1

enrico@debian:~$ apt list texlive
Listing... Done
texlive/stable,now 2016.20170123-5 all [installed]
enrico@debian:~$ apt list texstudio
Listing... Done
texstudio/stable,now 2.11.2+debian-1 amd64 [installed]
  • For those looking for an apt command sudo apt-get install cm-super. – kabanus Jan 9 '18 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.