6

I installed TeX Live. It had originally asked what I wanted the default paper size to be. I forgot to change it from A4 to Letter. Now the default paper size is A4.

How can I change the default size to Letter now that it is installed? The installation took several hours so I do not want to go through it again.

When setting a default paper size during set up what exactly happens during install?

I realize that I can specify a paper size in the header of the document but am trying to set the default to what it should have been.

8

From the command line, you can call tlmgr with the paper option to see what the default setting is, and change it if you supply an argument. So use

tlmgr paper letter

From the tlmgr documentation on paper:

paper

paper [a4|letter]
[xdvi|pdftex|dvips|dvipdfmx|context|psutils] paper [papersize|--list]
paper --json

With no arguments (tlmgr paper), shows the default paper size setting for all known programs.

With one argument (e.g., tlmgr paper a4), sets the default for all known programs to that paper size.

With a program given as the first argument and no paper size specified (e.g., tlmgr dvips paper), shows the default paper size for that program.

With a program given as the first argument and a paper size as the last argument (e.g., tlmgr dvips paper a4), set the default for that program to that paper size.

With a program given as the first argument and --list given as the last argument (e.g., tlmgr dvips paper --list), shows all valid paper sizes for that program. The first size shown is the default.

If --json is specified without other options, the paper setup is dumped in JSON format. For the format of JSON output see tlpkg/doc/JSON-formats.txt, format definition TLPAPER.

Incidentally, this syntax of having a specific program name before the paper keyword is unusual. It is inherited from the longstanding texconfig script, which supports other configuration settings for some programs, notably dvips. tlmgr does not support those extra settings.

  • 1
    I get this error tlmgr: action paper not supported in usermode. Any ideas? – redapemusic35 Oct 24 '19 at 18:04
  • @redapemusic35: Maybe run the command prompt as administrator and try again. It may depend on how you installed TeX Live to begin with (in administrator or user mode). – Werner Oct 24 '19 at 18:14
  • I followed the directions found here: tex.stackexchange.com/a/262011/105994 and then did: tex.stackexchange.com/a/389949/105994, and it worked. – redapemusic35 Oct 24 '19 at 20:50
  • I currently see same error reported by @redapemusic35 on Ubuntu 19.10. I suspect the OS folks broke tlmgr, part of their effort to disable the package manager. I get same error as root or as user. – pauljohn32 Dec 18 '19 at 22:34
  • Correct answer on Ubuntu 19.10 is supposed to be "$ sudo paperconfig -p letter". Will save /etc/papersize. Even after that, running pdflatex creates an A4 document. I suspect I've got a wrong setting saved somewhere else. – pauljohn32 Dec 18 '19 at 22:43
5

This is described in the Quick install instructions:

The default is to configure the programs for the A4 paper size. To make the default be 8.5x11 letter-size paper, you can use the ‘o’ menu option before i(nstalling), or run tlmgr paper letter after installation (and after setting your PATH).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.