10

Is there any way to force todonotes to place comment bubbles only on the left side of the page, or only on the right side of the page? My corporate document template is two-sided, so todonotes puts the bubbles on the right margin for odd-facing pages, and the left margin for even-facing pages. I need to make the PDF viewing window bigger just to see comments on both odd and even pages. Display area on my tiny laptop is a premium.

I've already \reversemarginpar after invoking packages todonotes and geometry, but comment bubbles still show up in both margins.

I tried to force one-sided output using \documentclass[oneside]{corpTemplate}, but I get a message indicating that the corporate template does not permit one-sidedness.

I've posted this to the LaTeX Community.

3
  • might be easier to hack your corpTemplate to dispense with the sidedness check. Jan 12, 2018 at 1:26
  • 1
    That's what I ended up doing -- applying a document template switch that designates the document as one that isn't published. I had to comment out commands that are for documents that are to be published. I will restore them in the final draft, when the comments in the margins are no longer needed. A kluge, for sure, but a solution nevertheless. Who's to say that it is actually more sensible to have a direct todonotes switch?
    – user36800
    Jan 12, 2018 at 3:54
  • 1
    An alternative could be the usage of luatodonotes. They state in the documentation: "Compared to the classical todonotes this package has more advanced algorithms and more configuration options to control the position of the notes on the page. Additionally, we are able to place notes at almost every position on the page, e. g., in floating environments or in footnotes." and the syntax is almost similar to todonotes.
    – Nico
    Nov 23, 2021 at 11:11

1 Answer 1

0

By default, todonotes uses \marginpar internally, which is actually defined in base/latex.ltx. The page-switching features are "built in" and I ran into this same problem as you did in a situation where I couldn't switch to using LuaLaTeX or modifying the underlying class (albeit with the Springer-Nature latex package sn-article instead of your corpTemplate).

There are two ways to proceed: either (a) redefine \marginpar to something else where you can control the layout (e.g. an answer along the lines of \let\marginpar\marginnote...) or, (b) a far easier method is to just tell marginpar itself that the document is one-sided. Amazingly, this works by just flicking the "please change sides" switch to "off" in the preamble:

\makeatletter 
\@mparswitchfalse%
\makeatother
\normalmarginpar %for right-handed notes and lines, or 
%\reversemarginpar %if you want them on the left of your twosided document. 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.