0

My code follows:

\documentclass{book}
\usepackage{lipsum}

\setlength{\paperheight}{9truein}%
\setlength{\paperwidth}{8truein}%

\makeatletter
\setlength\oddsidemargin{5pc}
\addtolength\oddsidemargin{-1in}    
\setlength\@tempdima{\paperwidth}
\addtolength\@tempdima{-\textwidth}
\addtolength\@tempdima{-5pc}
\setlength\evensidemargin{\@tempdima}
\addtolength\evensidemargin{-1in}
\makeatother
\usepackage[a4,cam,center,info]{crop}
\setlength\textwidth{30pc}
\setlength\textheight{40pc}
\begin{document}
\lipsum
\end{document}

Trim marks and got cut in the output PDF file, refer the below image for your reference:

enter image description here

But I need the PDF output with Trim marks and the Trim marks should not be cut, e.g.,

enter image description here

Please suggest the possibilities...

1
  • 1
    You should also use the geometry package to set up your margins rather than messing around with \textwidth and \textheight directly. Commented Jan 12, 2018 at 9:10

1 Answer 1

1

The problem is that the "paper" that you ask crop to put your document on (A4) doesn't leave enough space for your desired paper size plus the marks. So just choose another paper size as option for crop.

If none of the standard sizes of the package is convenient for you, you can also choose a custom one, e.g. [width=10truein,height=11truein]

\documentclass{book}
\usepackage{lipsum}

\setlength{\paperheight}{9truein}%
\setlength{\paperwidth}{8truein}%

\makeatletter
\setlength\oddsidemargin{5pc}
\addtolength\oddsidemargin{-1in}    
\setlength\@tempdima{\paperwidth}
\addtolength\@tempdima{-\textwidth}
\addtolength\@tempdima{-5pc}
\setlength\evensidemargin{\@tempdima}
\addtolength\evensidemargin{-1in}
\makeatother

\usepackage[width=10truein,height=11truein,cam,center,info]{crop}

\setlength\textwidth{30pc}
\setlength\textheight{40pc}
\begin{document}
\lipsum
\end{document}
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .