0

I'm using glosses in LyX and this makes the first line italic by different. Is there a way to change this?

closed as unclear what you're asking by Raaja, user156344, Stefan Pinnow, CarLaTeX, Mensch Feb 17 at 18:08

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to TeX.SX! Can you add a minimal example of LaTeX code? – egreg Jan 13 '18 at 10:29
  • I'm voting to close this question as off-topic because Not much info is provided to explain the issue. – Raaja Feb 17 at 17:37
2

The covington package uses a version of the gloss macros developed by Marcel van der Goot, which also for the basis for the cgloss4e package used by other linguistics example packages. The following macros are defined to set the font for the first, second or third lines of a \gll or \glll set.

\eachwordone
\eachwordtwo
\eachwordthree

So to make the first line non-italic you can add the following to the preamble:

\let\eachwordone\normalfont

To do this in LyX you go to Document Settings -> LaTeX Preamble. Make sure you add it after the covington package is loaded.

There are also other example numbering packages available, which depending on your needs might be better.

  • Thank you! is it also possible to define an indentation of the third line? I have not been able to to do this by inserting /indent latex code, thin spaces etc. – Noa Jan 13 '18 at 22:25
1

Note that as of covington 2.0, the above can also be done via

\renewcommand*\glosslineone{\normalfont}

Indentation of the third (translation) line could be done with

\let\saveglt\glt
\def\glt{\saveglt\hspace*{1em}}

or, if you use the new macro \glot of covington 2.0 rather than \glt:

\renewcommand*\glosslinetrans[1]{\hspace*{1em}\covenquote{#1}}

(adjust the length 1em to your needs)

Note that with LyX, you'd need to embrace all this in \AtBeginDocument{...} in the preamble, since covington is loaded after the user preamble.

Not the answer you're looking for? Browse other questions tagged or ask your own question.