0

How can I succesfully install texlive on my USB hard drive?

I try to install texlive with debian on a USB harddrive for dual-boot usage. Therefore I change the installation properties: the path is set to /media/user/drivename/texlive/2017. I also let windows binaries be installed. However, the installer fails. I tried other configurations too: portable, only /media/.../texlive as path.

Trying to install with standard configuration seems fine, I have let the installer do its work until "Installing acmart", at last it would have stopped at a2ping.x86_64-linux, which was installed with standard config here.

Permissions are drwxrwxrwx for the texlive folder structure. I can touch files and make folders as user and as root on the usb drive. The perl version is 5.24.1.

Google let me down this time...

root@pc:/home/<user>/Downloads/install-tl-20180104# ./install-tl --profile installation.profile
ABORTED TL INSTALLATION FOUND: installation.profile (in /home/<user>/Downloads/install-tl-20180104)
Do you want to continue with the exact same settings as before (y/N): N
Automated TeX Live installation using profile: installation.profile
Loading http://ctan.math.washington.edu/tex-archive/systems/texlive/tlnet/tlpkg/texlive.tlpdb
Installing TeX Live 2017 from: http://ctan.math.washington.edu/tex-archive/systems/texlive/tlnet (verified)
Platform: x86_64-linux => 'GNU/Linux on x86_64'
Distribution: net  (downloading)
Using URL: http://ctan.math.washington.edu/tex-archive/systems/texlive/tlnet
Directory for temporary files: /tmp/cYINAomrRd
Installing to: /media/<user>/<drivename>/texlive/2017
Installing [0001/3717, time/total: ??:??/??:??]: 12many [376k]
tar: tex/latex/12many/12many.sty: Cannot change ownership to uid 0, gid 0: Operation not permitted
tar: tlpkg/tlpobj/12many.tlpobj: Cannot change ownership to uid 0, gid 0: Operation not permitted
tar: Exiting with failure status due to previous errors    
untar: untarring /tmp/cYINAomrRd/HLBVkLBWTZ/12many.tar failed (in /media/<user>/<drivename>/texlive/2017/texmf-dist)
TLPDB::_install_package: untar failed
Installation failed.
Rerunning the installer will try to restart the installation.
Or you can restart by running the installer with:
  install-tl --profile installation.profile [EXTRA-ARGS]
./install-tl: Writing log in current directory: /home/<user>/Downloads/install-tl-20180104/install-tl.log
  • Have you tried installing to your Linux home folder, then copying the installation to USB? – user139954 Jan 13 '18 at 15:48
  • No, I try it out now. – Stefan Bollmann Jan 13 '18 at 15:53
  • I installed with portable option as user and copied the folder. cp -r texlive /media/user/drivename/. I got several cp: cannot create symbolic link /media/user/drivename/texlive/2017/bin/x86_64-linux/packagename Function not implemented warnings. – Stefan Bollmann Jan 13 '18 at 18:45
  • Unfortunate. Works on Windows. Seems that the underlying problem has to do with the Linux symbolic links (which have a different format than Windows "shortcut" files). – user139954 Jan 13 '18 at 21:34
  • I read that I should use FAT32 for partitioning the usb drive. However, for sharing virtual drives I later changed to exFAT. Now I read that unix links are not supported on FAT partitions. This might be the issue... I try later, but that needs time. – Stefan Bollmann Jan 13 '18 at 21:41
0

In the end I installed TexLive on my Linux folder and copied the data to the USB drive. The links that cannot be created on a FAT drive were followed to get a working system. This may fail if I do updates in the future.

./install-tl -portable 
cp -rL 2019 /mnt/d/texlive/2019
# ..and deleted the folder after successful copy. 
  • Did you do anything about the permissions? – Ivan Kapitonov Jan 16 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.