1

I hope this is a simple question with a simple answer. I am using WinEdt and there is a TeX menu with "Make Index" as an option.

I have gone into Execution Modes and found the "MakeIndex" entry, added the executable in MikTeX and (based on the note here tried to add the "-s [name].ist" to the command line.

Here is an image of what my execution mode screen looks like: enter image description here

But the "Make Index" command under the TeX menu item is ghosted, so I cannot run it.

There is also supposed to be a command line option in an Accessories|Run... command, but I don't have a Run command under the Accessories menu item.

Edit: I do have \makeindex in the source and .idx files are generated. I just don't have access to the MakeIndex tool within WinEdt---it is grayed out and the keyboard shortcut does not work.

enter image description here

Edit: I have been able to successfully use the commandline version by clicking Accessories|CommandLine. This ran without any errors.

  • Delete the contents of Executable field in Command Line and press OK. WinEdt will find makeindex on its own. – Arzigoglu Jan 14 '18 at 11:43
  • What do you mean with "ghosted"? Perhaps "grayed out", unavailable? If so, this means that you haven't generated a .idx needed to run makeindex. – Arzigoglu Jan 14 '18 at 12:20
  • What you call the Run command in the Accessories menu is probably Command Prompt. As to Make Index being greyed, it certainly means you have no .idx file. – Bernard Jan 14 '18 at 12:20
  • Do you have a \makeindex command in your .tex file that generates the .idx one? – Arzigoglu Jan 14 '18 at 12:25
  • @Arzigoglu, I do have a \makeindex command, and I also have .idx files in my directory. I removed the contents of "Executable" and WinEdt recreated them, but now there is a "(!)" next to the entry in the Execution Mode screen. "MakeIndex" is still grayed out. I'm attaching a screenshot showing the idx files. – David R Jan 14 '18 at 15:33
1

I don't think there is an editor that is able to run makeindex when there is not an .idx file with the same name of the .tex file.

To overcome this, try this. Just after

\documentclass{memoir}

add

\immediate\write18{makeindex people}

or

\immediate\write18{makeindex -s people.ist people}

if you have a people.ist style file and recompile the file.

  • Nice! This worked great! – David R Jan 14 '18 at 23:32
0

It appears that WinEdt simply does not have the capability to register any .idx files other than a generic one whose name is the same as the file being compiled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.