I am using Tex Live 2011 on Windows, and when I compile (vim-latex) my file:


% makes for prettier typography
% For slanted fractions e.g. 4/4



I get the following error:

template.tex|| File `xfrac.sty' not found.
template.tex|8 error| Emergency stop.
template.tex|| ==> Fatal error occurred, no output PDF file produced

Any ideas?

  • Can your TeX system find xfrac.sty if you leave off the \usepackage(microtype} instruction? – Mico Jan 13 '12 at 21:37
  • No, it still can't find it. In fact it installed both amsmath and microtype packages fine, but for some reason xfrac is giving it trouble. – Andriy Drozdyuk Jan 13 '12 at 21:39
  • If its not installed (for whatever reason), try tlmgr install --reinstall xfrac from your command prompt. – Werner Jan 13 '12 at 21:41
  • 1
    @drozzy: Then try Boris' suggestion using tlmgr install --reinstall l3packages. – Werner Jan 13 '12 at 21:52
  • 1
    @drozzy I believe you should read about how to update and maintain your TeX installs. How it works. This thread has gone into a dead-spin of trial and error. See MikTeX: Maintenance, Update, Install packages. Under TeXlive you should look up: Update and in TeXlive under the options that have been suggested by users on this page – zeroth Jan 15 '12 at 20:48

The command tlmgr search --file xfrac.sty says that xfrac.sty is installed by the package l3packages. So installing this package from tlmgr interface (or updating it if you have an old version) will install this file.

  • Wow, I don't even know what this tlmgr thing is... Anyways I tried tlmgr update --self and then tlmgr install l3packages, but no cigar. I get the same error: xfrac.sty not found. – Andriy Drozdyuk Jan 13 '12 at 21:45
  • Try tlmgr update --all – Boris Jan 13 '12 at 21:50
  • Will try that at work. What about if I don't use Tex Live - but only Mike Tex (like I do at home): there is no tlmgr command... – Andriy Drozdyuk Jan 15 '12 at 20:30
  • @drozzy MikTeX installs missing packages "on the fly" during compilation, so it should take care of this issue for you automagically. – Sharpie Jan 15 '12 at 20:55
  • @Sharpie It says the same thing xfrac.sty not found etc... I don't understand why they had to move things around? Do they have a special committee on "how to confuse people"? PS: I am using nicefrac in the meantime - while I try to fix this issue... – Andriy Drozdyuk Jan 15 '12 at 21:22

According to the file datestamps on the CTAN, the xfrac package was last updated on 12/29/2011. I suppose it's possible that if you ran tlmgr update --all since then, something migh have gone wrong in the update process without you noticing.

Try running

tlmgr install --reinstall xfrac

from the command line and see if this brings the needed relief. You may have to be in the directory c:\texlive\2011\bin\win32 (or wherever tlmgr.bat is located on your Windows system).

Addendum: I see from your comment that your current CTAN repository is ctan.cms.math.ca. For what it's worth, the xfrac package seems to be available at the CTAN mirror site mirrors.med.harvard.edu (and probably many other CTAN mirror sites too). You might want to try running the command

tlmgr option repository http://mirror.ctan.org/systems/texlive/tlnet


tlmgr option repository http://mirrors.med.harvard.edu/ctan/systems/texlive/tlnet

from the command line (to reset tlmgr's default CTAN repository information) before (re)running the tlmgr install ... command I suggested earlier.

  • tlmgr: package repository http://ctan.cms.math.ca/tex-archive/systems/texlive/tlnet package xfrac not present in package repository. – Andriy Drozdyuk Jan 13 '12 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.