2

I am using \AtBeginSection to produce a table of contents for my Beamer presentation that appears at the beginning of each section. However, when I pass the handout option to beamer to make a copy of slides for my class to print the ToC slide disappears from the output.

Is there a way to maintaint the \AtBeginSection output at the start of each section while also producing handouts with one frame per PDF page?

Here's a MWE:

\documentclass[handout]{beamer}

\AtBeginSection[]  
{
\begin{frame}<beamer> 
\frametitle{Outline}
\tableofcontents[currentsection]  
\end{frame}
}
\begin{document}
\section{test section}

\begin{frame}
test slide
\end{frame}
\end{document}
  • 4
    Why do you add <beamer> at all? If you only want to avoid article mode you could use another option. – TeXnician Jan 15 '18 at 16:50
  • @TeXnician Oh wow, i hadn't even noticed the <beamer> part was there. The \AtBeginSection stuff is just something I copied from the web 10 years ago and have been using it ever since. Indeed, removing <beamer> produces the desired result. Thanks! – Ubiquitous Jan 15 '18 at 16:53
  • @TeXnician Would you like to add an answer? – user36296 Jan 17 '18 at 0:16
6

You are using the following line:

\begin{frame}<beamer>

which says that the frame should only be shown in beamer mode, which does not include the handout. If you want it to be visible on a handout, remove that specification.

Note: If that is to prevent the frame from being printed in article mode you can add another specification.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.