2
\documentclass[14pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
% Double Spacing
\usepackage{setspace}
\doublespacing
\usepackage{extsizes} % For size 14 font
\usepackage{tocloft} % For Table of Contents
\usepackage{array} % To allow customization of tables
\usepackage{multicol}
\usepackage{xcolor}
\usepackage{lipsum}
\usepackage{tabu} % Better tabulars (==tabu)
% Indention Settings
\usepackage{indentfirst}
\usepackage{parskip}
\setlength{\parindent}{30pt}
% Hyphens
\tolerance=1
\emergencystretch=\maxdimen
\hyphenpenalty=10000
\hbadness=10000
% Ragged Right Definition, fixes indents
\makeatletter
\newcommand\iraggedright{%
  \let\\\@centercr\@rightskip\@flushglue \rightskip\@rightskip
  \leftskip\z@skip}
\makeatother

\renewcommand\cftsecleader{\cftdotfill{\cftdotsep}} % Table of Contents x2

With this preamble, everything indents fine unless a table comes first. If there is, the indents vanish. Using normal raggedright does not fix the issue. \par doesn't do anything nor does \indent.

Here is an example of it not working:

Here is the code for this:

\section{Expositions}

\noindent\fcolorbox{black}{white}{%
    \minipage[t]{\dimexpr0.48\linewidth-2\fboxsep-2\fboxrule\relax}
        \centering
        Latine         
        \vspace{0.25cm}
        \hrule
        \vspace{0.25cm}
            Adfuit ille quidem, sed nec sollemnia verba\\[5pt]
            nec laetos vultus nec felix attulit omen.\\[5pt]
            fax quoque, quam tenuit, lacrimoso stridula fumo\\[5pt]
            usque fuit nullosque invenit motibus ignes.\\[5pt]
    \endminipage}\hfill
    \fcolorbox{black}{white}{%
    \minipage[t]{\dimexpr0.48\linewidth-2\fboxsep-2\fboxrule\relax}
        \centering
        In English
        \vspace{0.25cm}
        \hrule
        \vspace{0.25cm}
            He was present indeed, but neither solumn words\\[5pt]
            nor happy expressions nor a lucky omen did he bring.\\[5pt]
            The torch also, which he held, was hissing with tearful smoke\\[5pt]
        constantly and found no fires even with movement.\\[5pt]
    \endminipage}\\[10pt]
% Citation:
\centering
Ovid, \textit{Metamorphoses} 10.1 4-7

\iraggedright


<text>


<text>
  • Welcome to TeX.SX! The document part of the example is missing and it's quite likely the place where the problem lies. – egreg Jan 15 '18 at 22:19
  • why set \tolerance=1 ?? – David Carlisle Jan 15 '18 at 22:21
  • I have added to code for the document. I am not sure why @DavidCarlisle I just copy pasted from somewhere on this website – Migillope Jan 15 '18 at 22:22
  • The markup is completely wrong!! the issue is unrelated to your preamble. \\ does not start a new paragraph it forces a linebreak in the current paragraph so Ovid... is not the start of a paragraph. so not indented. use a blank line not \\ – David Carlisle Jan 15 '18 at 22:24
  • your definition of \iraggedright has \leftskip\z@skip which is equivalent to \noindent. never mind the problems pointed out by @DavidCarlisle. – barbara beeton Jan 15 '18 at 23:11
1

The issue here is the use of an ungrouped \centering to typeset your citation as the following example highlights:

enter image description here

\documentclass{article}

\usepackage{lipsum}

\makeatletter
\newcommand\iraggedright{%
  \let\\\@centercr\@rightskip\@flushglue \rightskip\@rightskip
  \leftskip\z@skip}
\makeatother

\begin{document}

{\centering First citation \par}

\iraggedright
\lipsum[1]

\centering Second ciation

\iraggedright
\lipsum[1]

\end{document}

Note how the First citation is followed by a paragraph having an indent, while Second citation does not. You're setup is similar to Second citation.

So, instead use

{\centering <citation> \par}

or

\begin{center}
<citation>
\end{center}
  • This worked, my solution was incidental. Thank you! – Migillope Jan 15 '18 at 22:35
  • @Migillope: Consider using ragged2e for switching between justification styles. – Werner Jan 15 '18 at 22:41
  • @Migillope: Note that a page break between the two boxes and the line containing the <citation> is not only possible, but also mildly encouraged. – GuM Jan 15 '18 at 22:48
  • @GuM: I'm not sure I understand what you're saying. My two boxes and the citation for those boxes should be on different pages? If so, I cannot do that as the formating for citing on this paper is specified in the rubric, so there is little wiggle room as far as that goes. – Migillope Jan 16 '18 at 2:05
  • @Migillope: No, I’m saying that the boxes and the citation should always be kept on the same page, but that the code presented in this answer does not guarantee this, since, on the contrary, it not only permits, but also mildly encourages, a page break just before the citation. The answer by egreg also suffered from this defect in its first version, but it has now been corrected. – GuM Jan 16 '18 at 18:09
2

Do yourself a favor and define structures for your input.

\documentclass[14pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
% Double Spacing
\usepackage{setspace}
\doublespacing
\usepackage{extsizes} % For size 14 font
\usepackage{tocloft} % For Table of Contents
\usepackage{array} % To allow customization of tables
\usepackage{multicol}
\usepackage{xcolor}
\usepackage{lipsum}
\usepackage{tabu} % Better tabulars (==tabu)
% Indention Settings
\usepackage{indentfirst}
\usepackage{parskip}
\setlength{\parindent}{30pt}
% Hyphens
\emergencystretch=\maxdimen
\hyphenpenalty=10000
\hbadness=10000
% Ragged Right Definition, fixes indents
\makeatletter
\newcommand\iraggedright{%
  \let\\\@centercr\@rightskip\@flushglue \rightskip\@rightskip
  \leftskip\z@skip}
\makeatother

\renewcommand\cftsecleader{\cftdotfill{\cftdotsep}} % Table of Contents x2

\newenvironment{exposition}[1]
 {\begin{center}\def\expositioncaption{#1}}
 {%
  \fbox{\usebox{\leftexpositionbox}}%
  \hfill
  \fbox{\usebox{\rightexpositionbox}}%
  \\*[10pt]
  \expositioncaption
  \end{center}%
 }
\newsavebox{\leftexpositionbox}
\newsavebox{\rightexpositionbox}
\newcommand{\leftexposition}[2]{%
  \genericexposition{\leftexpositionbox}{#1}{#2}%
}
\newcommand{\rightexposition}[2]{%
  \genericexposition{\rightexpositionbox}{#1}{#2}%
}
\newcommand{\genericexposition}[3]{%
  \sbox{#1}{%
    \begin{minipage}[t]{\dimexpr0.48\linewidth-2\fboxsep-2\fboxrule\relax}
    \centering
    \strut#2\par\vspace{0.25cm}\hrule\vspace{0.25cm}#3\strut\par
    \end{minipage}%
  }%
}

\begin{document}

\iraggedright

\section{Expositions}

\begin{exposition}{Ovid, \textit{Metamorphoses} 10.1 4--7}
\leftexposition{Latine}{%
  Adfuit ille quidem, sed nec sollemnia verba\\[5pt]
  nec laetos vultus nec felix attulit omen.\\[5pt]
  fax quoque, quam tenuit, lacrimoso stridula fumo\\[5pt]
  usque fuit nullosque invenit motibus ignes.
}
\rightexposition{In English}{%
  He was present indeed, but neither solumn words\\[5pt]
  nor happy expressions nor a lucky omen did he bring.\\[5pt]
  The torch also, which he held, was hissing with tearful smoke\\[5pt]
  constantly and found no fires even with movement.
}
\end{exposition}

\lipsum[1-2]

\end{document}

enter image description here

Just to show what happens if you remove all the dreaded settings

14pt
\doublespacing
\usepackage{parskip}

enter image description here

What can be said in one page should never waste two.

  • +1, but I insist that I’d say \par \nobreak\vspace{10pt} \espositioncaption. – GuM Jan 15 '18 at 23:44
  • @GuM I agree... – egreg Jan 16 '18 at 0:06
  • Oh my goodness that is very convenient, thank you for typing that out, I will promptly steal it. – Migillope Jan 16 '18 at 0:28
0

I figured out my problem, the \noindent wasn't applying to just the minipage. Fix was bracketing off the minipage.

Should I delete the post? I am new to this.

  • This is not the correct answer – David Carlisle Jan 15 '18 at 22:25
  • I am not sure how to respond to that, it fixed my issue, you can test yourself. I didn't use \\ to start new paragraphs, those were within my tables. The actual text was in the <text> things I left there. Perhaps you didn't see the scroll bar on the code? – Migillope Jan 15 '18 at 22:27
  • you have ge}\\[10pt] % Citation: \centering Ovid, so Ovid is line 2 of the paragraph started by the minipage, that \\ should be deleted and replaced by a blank line if Ovid is the start of a paragraph. – David Carlisle Jan 15 '18 at 22:29
  • This solution broke the centering of the citation, see the accepted solution. – Migillope Jan 15 '18 at 22:36
  • well yes I was concentrating on fixing one error at a time:-) – David Carlisle Jan 15 '18 at 22:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.