4

I use TexMaker and want to generate glossaries, right now I found

\usepackage[automake]{glossaries}

Doesn't help (don't know why and I need time to check), so I want to use manually way to generate, I can run command in cmd outside TeXMaker makeglossaries.exe my_file_name:

makeglossaries.exe hand_book_draft
makeglossaries version 4.35 (2017-11-14)
added glossary type 'main' (glg,gls,glo)
added glossary type 'acronym' (alg,acr,acn)
Warning: File 'hand_book_draft.glo' is empty.
Have you used any entries defined in glossary 'main'?
Remember to use package option 'nomain' if you
don't want to use the main glossary.
makeindex  -s "hand_book_draft.ist" -t "hand_book_draft.alg" -o "hand_book_draft.acr" "hand_book_draft.acn"
This is makeindex, version 2.15 [MiKTeX 2.9.6500 64-bit] (kpathsea + Thai support).
Scanning style file ./hand_book_draft.ist.............................done (29 attributes redefined, 0 ignored).
Scanning input file hand_book_draft.acn....done (33 entries accepted, 0 rejected).
Sorting entries....done (170 comparisons).
Generating output file hand_book_draft.acr....done (36 lines written, 0 warnings).
Output written in hand_book_draft.acr.
Transcript written in hand_book_draft.alg.

everything is OK, glossaries printed. Then I add it into TeXMaker user command as:

makeglossaries %

However, when I run this in the TexMaker, it shows:

Process started

makeglossaries: The script engine could not

be found. makeglossaries: Data: scriptEngine="perl.exe"

Process exited with error(s)

What is the problem??

  • 1
    It seems like a path problem: cmd is finding perl.exe but TeXMaker isn't. I don't know enough about Windows to help, but you could try makeglossaries-lite instead of makeglossaries. It's not as good as makeglossaries, but it's a Lua rather than Perl script. – Nicola Talbot Jan 16 '18 at 8:57
7

The answere is very simple (after hours of searching):

  • Just download: ActivePerl.exe
  • Navigate to C:\Program Files\MiKTeX 2.9\miktex\bin\x64 and run perltex.exe

This should save you from getting the error code

  • Now you can use a manual cmd in TexMaker to generate your glossaries. See at the end of this Link

Then, in Texmaker, go to User -> User Commands -> Edit User Commands. Choose command 1

Menuitem = makeglossaries Command = makeglossaries % Now push Alt+Shift+F1 and then -> F1

Note, for use with the "use build directory" option of Texmaker: makeglossaries needs to find the aux file. Thankfully, while Texmaker does not help there, the option -d of makeglossaries provides for the subdirectory case. Hence the Command in this case should be: Command = makeglossaries -d build % instead.

Please don't forget to restart TeXMaker after your work!

The automake option in glossaries doesn't work for me too right now. But I will go on and let you now.

  • 1
    Regarding the automake option, check the .log file for runsystem. In restricted mode it should be followed by the message "executed safely (allowed)" if it was allowed to run. If instead it's followed by the message "disabled", then the shell escape is disabled, which means that the automake option can't work. If the message is "disabled (restricted)" then the unrestricted (less secure) mode is needed. – Nicola Talbot Mar 12 '18 at 9:39
  • 1
    For those who can't see the now-deleted answer by Gihanmu (which was deleted because it was a comment rather than an answer despite containing useful information), you apparently also need to restart TeXMaker after configuring it. – Nicola Talbot Mar 17 '18 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.