1

Having installed getnonfreefonts, trying sudo getnonfreefonts --sys luximono gives me either one of the following errors:

curl: (55) getpeername() failed with errno 22: Invalid argument
curl: (7) Failed to connect to mirrors.ctan.org port 80: Operation timed out

Using sudo getnonfreefonts --sys vntex-nonfreeinstalls VnTex without problem, but all other fonts do not work.

Running the command with --debug gives me this:

DEBUG: getnonfreefonts rev. 2017-06-02.
DEBUG: argv[0]: '/usr/local/bin/getnonfreefonts'
DEBUG: argv[1]: '--sys'
DEBUG: argv[2]: '--debug'
DEBUG: argv[3]: 'luximono'
DEBUG: opt_sys=1
DEBUG: opt_user=0
DEBUG: PATH[0]: '/opt/local/bin'.
DEBUG: PATH[1]: '/opt/local/sbin'.
DEBUG: PATH[2]: '/opt/local/bin'.
DEBUG: PATH[3]: '/opt/local/sbin'.
DEBUG: PATH[4]: '/usr/local/bin'.
DEBUG: PATH[5]: '/usr/bin'.
DEBUG: PATH[6]: '/bin'.
DEBUG: PATH[7]: '/usr/sbin'.
DEBUG: PATH[8]: '/sbin'.
DEBUG: PATH[9]: '/Library/TeX/texbin'.
DEBUG: PATH[10]: '/opt/X11/bin'.
DEBUG: Search for kpsewhich in PATH:
DEBUG: Found '/Library/TeX/texbin/kpsewhich'.
DEBUG: TEXMFLOCAL[0]: '/usr/local/texlive/texmf-local'.
DEBUG: Extracting the first element of the list (TEXMFLOCAL[0]):
DEBUG: TEXMFLOCAL[0]='/usr/local/texlive/texmf-local'.
DEBUG: Removing leading "!!" and trailing "//" and set INSTALLROOT:
DEBUG: INSTALLROOT='/usr/local/texlive/texmf-local'.
DEBUG: Environment variable TMPDIR not set.
DEBUG: Environment variable TEMP not set.
DEBUG: Internal variable SYSTMP set to '/tmp'.
DEBUG: Internal variable tmpdir set to '/tmp/getfont-10295'.
DEBUG: Signal handlers installed. Don't expect too much on Windows.
DEBUG: No wget binary found on your system, trying curl.
DEBUG: Running 'curl -O https://www.tug.org/~kotucha/getnonfreefonts/getfont.pl'.
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 32681  100 32681    0     0  32681      0  0:00:01 --:--:--  0:00:01  104k
DEBUG: Running 'perl ./getfont.pl --installroot=/usr/local/texlive/texmf-local --debug --sys --use_curl luximono'.
------------------------------------------------------
Installation directory: /usr/local/texlive/texmf-local
------------------------------------------------------

===================
Package 'luximono':
===================

Downloading 'http://mirrors.ctan.org/fonts/LuxiMono.zip'


  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
curl: (55) getpeername() failed with errno 22: Invalid argument
                                                              [download failed]

Download failed.  Please try again.
DEBUG: Info: Execute updmap-sys if exit status is 2.
DEBUG: Exit status of getfont.pl is 0.
DEBUG: Executing Signal Handler:
DEBUG: unlink '/tmp/getfont-10295/getfont.pl'.
DEBUG: rmdir  '/tmp/getfont-10295'.

Or this (alternating):

DEBUG: getnonfreefonts rev. 2017-06-02.
DEBUG: argv[0]: '/usr/local/bin/getnonfreefonts'
DEBUG: argv[1]: '--sys'
DEBUG: argv[2]: '--debug'
DEBUG: argv[3]: 'luximono'
DEBUG: opt_sys=1
DEBUG: opt_user=0
DEBUG: PATH[0]: '/opt/local/bin'.
DEBUG: PATH[1]: '/opt/local/sbin'.
DEBUG: PATH[2]: '/opt/local/bin'.
DEBUG: PATH[3]: '/opt/local/sbin'.
DEBUG: PATH[4]: '/usr/local/bin'.
DEBUG: PATH[5]: '/usr/bin'.
DEBUG: PATH[6]: '/bin'.
DEBUG: PATH[7]: '/usr/sbin'.
DEBUG: PATH[8]: '/sbin'.
DEBUG: PATH[9]: '/Library/TeX/texbin'.
DEBUG: PATH[10]: '/opt/X11/bin'.
DEBUG: Search for kpsewhich in PATH:
DEBUG: Found '/Library/TeX/texbin/kpsewhich'.
DEBUG: TEXMFLOCAL[0]: '/usr/local/texlive/texmf-local'.
DEBUG: Extracting the first element of the list (TEXMFLOCAL[0]):
DEBUG: TEXMFLOCAL[0]='/usr/local/texlive/texmf-local'.
DEBUG: Removing leading "!!" and trailing "//" and set INSTALLROOT:
DEBUG: INSTALLROOT='/usr/local/texlive/texmf-local'.
DEBUG: Environment variable TMPDIR not set.
DEBUG: Environment variable TEMP not set.
DEBUG: Internal variable SYSTMP set to '/tmp'.
DEBUG: Internal variable tmpdir set to '/tmp/getfont-10337'.
DEBUG: Signal handlers installed. Don't expect too much on Windows.
DEBUG: No wget binary found on your system, trying curl.
DEBUG: Running 'curl -O https://www.tug.org/~kotucha/getnonfreefonts/getfont.pl'.
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 32681  100 32681    0     0  32681      0  0:00:01 --:--:--  0:00:01  125k
DEBUG: Running 'perl ./getfont.pl --installroot=/usr/local/texlive/texmf-local --debug --sys --use_curl luximono'.
------------------------------------------------------
Installation directory: /usr/local/texlive/texmf-local
------------------------------------------------------

===================
Package 'luximono':
===================

Downloading 'http://mirrors.ctan.org/fonts/LuxiMono.zip'


  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:01:14 --:--:--     0curl: (7) Failed to connect to mirrors.ctan.org port 80: Operation timed out
                                                              [download failed]

Download failed.  Please try again.
DEBUG: Info: Execute updmap-sys if exit status is 2.
DEBUG: Exit status of getfont.pl is 0.
DEBUG: Executing Signal Handler:
DEBUG: unlink '/tmp/getfont-10337/getfont.pl'.
DEBUG: rmdir  '/tmp/getfont-10337'.

What is wrong?

closed as off-topic by egreg, Stefan Pinnow, Kurt, Bobyandbob, CarLaTeX Jan 17 '18 at 15:30

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Indeed, it seems that there are some problems. Be patient and retry tomorrow. – egreg Jan 16 '18 at 22:36
  • I'm not sure if it's related, but also www.ctan.org seems down. – egreg Jan 16 '18 at 23:24
  • 4
    I'm voting to close this question as off-topic because the issue was due to announced maintenance of the main server for CTAN – egreg Jan 17 '18 at 12:20
  • Ok. Fair enough. It is not a question on Tex after all, even though it is one that Tex uses may have. – Kenji Jan 17 '18 at 12:22
  • As it was scheduled maintenance, the question has become obsolete. Not that it was a bad one. – egreg Jan 17 '18 at 12:24
0

So the problem was indeed that the servers for ctan.org were down. I retried this morning and managed to install the fonts. Perhaps these errors are too cryptic for me, who don't understand much about curl, but if you get the errors below, it means that the server is likely down.

curl: (7) Failed to connect to mirrors.ctan.org port 80: Operation timed out
curl: (55) getpeername() failed with errno 22: Invalid argument

Not the answer you're looking for? Browse other questions tagged or ask your own question.