2

Using AUCTeX, with \documentclass[italian]{article} and babel, when I type quotes i get "< or ">:

\documentclass[italian]{article}
\usepackage{babel}
\begin{document}
"<bla">
\end{document}

It doesn't happen if I don't use babel:

\documentclass[italian]{article}
\begin{document}
``bla''
\end{document}
5

This behavior is actually expected and documented in AUCTeX manual:

5.4.1.2 Style Files for Different Languages

AUCTeX supports style files for several languages. Each style file may modify AUCTeX to better support the language, and will run a language specific hook that will allow you to for example change ispell dictionary, or run code to change the keyboard remapping.

‘italian’
Runs style hook TeX-language-it-hook. Pressing " will insert "< and "> depending on context.

If you're not satisfied with this behavior, customize TeX-quote-language-alist with M-x customize-variable RET TeX-quote-language-alist RET:

User Option: TeX-quote-language-alist

Used for overriding the default language-specific quote insertion behavior. This is an alist where each element is a list consisting of four items. The first item is the name of the language in concern as a string. See the list of supported languages above. The second item is the opening quotation mark. The third item is the closing quotation mark. Opening and closing quotation marks can be specified directly as strings or as functions returning a string. The fourth item is a boolean controlling quote insertion. It should be non-nil if if the special quotes should only be used after inserting a literal " character first, i.e. on second key press.

Using \usepackage[T1]{fontenc}, as suggested by @ChristianHupfer, is also recommended.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.