3

I must ask for your help despite my best efforts to find some similar solved problem online.

I am trying to get a full reference in the footnote using the \footfullcite{} commmand linking to a reference I have previously entered in the \thebibliography section. However I'm only managing to get a footnote written as the \bibitem item. I've read several times that using bibdesk would be easier, but I want full control of my references, and I want to access it in my main.tex this is why I want to stick with thebibliography.

My code goes something like (I use the memoir advanced template on MacTeX)

\documentclass[12pt,a4paper,article]{memoir} 

\usepackage[backend=bibtex,style=authoryear,natbib=true]{biblatex} 

\begin{document}

my text here \footfullcite{ref1}

\begin{thebibliography}{}
\bibitem{ref1} Name (year), Title, Town, Edition
\end{thebibliography} 

\end{document}

And this gives me:

Output

when I would like to have the full reference as I have entered it in my bibliography, with author (year), title, town, edition.

Bonus question, I would like to make a reference out of the caption of a figure, although when I have done so, the superscript always seem to be misaligned on the text. Any thought on that ?

I thank you very much in advance for your kind help !

4
  • Welcome to TSE. Please provide a MWE (minimal working example). Jan 17, 2018 at 21:09
  • Thanks for the welcome, could you elaborate on what a MWE is exactly ? Should I code some citations that are working correctly for me ?
    – Antoine
    Jan 17, 2018 at 21:13
  • Please read this. Jan 17, 2018 at 21:17
  • So that it can be copied and pasted, got it ! I'm working on it
    – Antoine
    Jan 17, 2018 at 21:21

1 Answer 1

1

The idea behind using biblatex (or bibtex) is to not manually format your bibliography.

Automatic

\documentclass[12pt,a4paper,article]{memoir} 

\usepackage[style=authoryear,natbib=true]{biblatex} 
\addbibresource{test.bib}

\begin{document}

my text here \footfullcite{knuth}

\printbibliography

\end{document}

with a file test.bin of the format

@article{knuth,
  author       = {Knuth, Donald E.},
  title        = {Some title},
  date         = 1984,
  location     = {Nice city},
  journal      = {good journal},
  volume       = {42}
}

Keep the manual formatting

\documentclass[12pt,a4paper,article]{memoir} 

\newcommand{\refa}{Name (year), Title, Town, Edition}

\begin{document}

my text here\footnote{\refa}

\begin{thebibliography}{}
\bibitem{refa} \refa
\end{thebibliography} 

\end{document}
6
  • Thank you very much for your help Sam, I'll try using a .bib file sometime but the manual formatting allows me to choose my own citation system (i.e. the French one, which is a bit different from the American citation norms) without having to understand fully how BibDesk work). Also, my thesis will be read in paper and not in pdf, so having fullfootcite allows for much smoother reading. Thanks again !
    – Antoine
    Jan 17, 2018 at 22:26
  • @Antoine biblatex is very customisable - it can very probably be adjusted to whatever citation style you want to use. Jan 17, 2018 at 22:42
  • I'm sorry but this still isn't working, I've copied your example and did a similar .bib file, but all I get in the footnote is "knuth" and not the full bibliographic reference.
    – Antoine
    Jan 18, 2018 at 8:51
  • 1
    @Antoine Did you run biber? see tex.stackexchange.com/questions/13509/… Jan 18, 2018 at 9:12
  • @samcartr Yes, I've changed the package to \usepackage[backend=biber,style=authoryear,natbib=true]{biblatex} and in TeXshop's - preferences - engine, I've set the BibTex engine to biber
    – Antoine
    Jan 18, 2018 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .