0

I am trying to create a component diagram using MetaUml embedded in TeX using LuaLaTeX. Every example form the manual I tried, worked well except from components.

\documentclass{article}
\usepackage{luamplib}
\title{Algo}
\author{Paul}
\begin{document}
\maketitle
\newpage
\tableofcontents
\newpage
\section{Reengineering Algo Architecture}
\subsection{Current System Structure}
\subsection{Restructured System}
\subsection{Extended  Restructured System}
    \subsubsection{System Component Structure}
        \begin{mplibcode}
            input metauml;
            beginfig(1);
            Component.C("Business Logic")();
            drawObject(C);
            endfig;
            end
        \end{mplibcode}
    \subsubsection{Inner Component Structure}
    \subsubsection{Usecasses}
\end{document}

This does not work for me, but it should, see page 14.

Error Message is:

Error Message

Error Message]

Cannot figure it out. Sorry.

Edit: Automatic installation was not correct:Fixed installation

But it is still not working.

  • please fix your example so that people can run it and debug the issue, make it a complete small document not a fragment with [...] – David Carlisle Jan 20 '18 at 12:25
  • Your example runs fine for me on TeX Live 2017. (Once I add the missing begin/end document environment). Are you sure you have metauml installed? – Thruston Jan 20 '18 at 12:52
  • If I comment out the input metauml; line, I get the same errors as you are seeing in your log. So my guess is that you don't have metauml installed properly. – Thruston Jan 20 '18 at 12:54
  • @Thruston yeah that could be a thing. I am new to TeX at all. I use texmaker. Do you got a link for me, on how to install it? Much appreciated. – Paul Jan 20 '18 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.