1

I have changed the value for parskip but this also affects the space between the last paragraph and the first item of the enumerate environment.

My questions are:

  1. Why would parskip affect something like that?
  2. How to prevent parskip from affecting it?
  3. Can I prevent parskip from affecting anything else than the separation between paragraphs?
  • 2
    parskip is a tex primitive so affects everything that is built from a primitive tex paragraph, so lists, section headings etc, more or less any text block. Classes designed for non zero parskip, or packages such as parskip reset compensating lengths where needed to allow for the space from parskip – David Carlisle Jan 20 '18 at 19:25
  • Try playing with \partopsep. You might have to make it negative. Oh, and \unskip\begin{enumerate}. – John Kormylo Jan 21 '18 at 1:26
1

There is an option to add parskip to your document class parameters like this:

\documentclass[pdftex, a4paper, parskip]{scrartcl}

By doing that the intends at the beginning of a paragraph are 0 and you still have the spaces between the other elements.

Altough, I think this just works for Koma-Script classes.

  • 1
    Indeed, it only works for the Koma-Script classes. This is one of the reasons I mostly use these classes for my documents, though. :-) – Franck Pastor Jan 20 '18 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.