5

I'm trying to write this reference :

[2]: World Health Organisation, 2017. Vision impairment and blindness. 
     Fact Sheet N°282. http://www.who.int/mediacentre/factsheets/fs282/fr/. 
     Accessed: 2017-11-30

I tried with :

@misc{OMS,
    author = {World Health Organisation},
    year = {2017},
    title = {Vision impairment and blindness},
    subtitle = {Fact Sheet N°282},
    url = {http://www.who.int/mediacentre/factsheets/fs282/fr/},
    note = {Accessed = 2017-11-30} 
}

But it gives me : [2] World Health Organisation. Vision impairment and blindness, 2017. Accessed = 2017-11-30.

I don't have all information like the first like I show you. Can You help me please ?

3
  • Welcome to TeX.SE. Which bibliography style do you employ? And, which citation call-out style do you employ: numeric, author-year, or something else?
    – Mico
    Commented Jan 21, 2018 at 19:08
  • I use \bibliographystyle{plain} and a numeric call-out
    – Mac.
    Commented Jan 21, 2018 at 19:12
  • If you can consider using biblatex it has an online entry type.
    – Bernard
    Commented Jan 21, 2018 at 19:31

1 Answer 1

9

Some suggestions:

  • The plain bibliography style doesn't know about a field called subtitle. Hence, combine the title and subtitle fields into a single title field.

  • Unless you're using either XeLaTeX or LuaLaTeX, the ° character in N°282 is going to give you grief. Change it to either N\textsuperscript{o}282 or No.~282.

  • The plain bibliography style doesn't know about a field called url either. (plain predates the World Wide Web. Really.) Hence, combine the url and note fields into a single note field. Do encase the URL string in a \url{...} wrapper; naturally, you should be loading the url package, preferably with the options hyphens and spaces. Also, please change "Accessed = 2017-11-30" to "Last accessed on 2017-11-30".

  • Last but not least, do encase the author field in double, not single, curly braces. That way, the author is marked as a "corporate author", and the entry will get sorted under W instead of under O. (Without the extra pair of curly braces, BibTeX will parse the name as consisting of two given names ("World" and "Health") and one surname ("Organization"); that's why BibTeX would try to sort the entry under "O" for "Organization". Not what you'd want or expect, right?

In short, write the entry as follows:

@misc{OMS,
    author= {{World Health Organisation}},
    year  = {2017},
    title = {Vision impairment and blindness, {Fact Sheet N\textsuperscript{o}282}},
    note  = {\url{http://www.who.int/mediacentre/factsheets/fs282/fr/}, 
             Last accessed on 2017-11-30},
}

A full MWE (minimum working example):

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@misc{OMS,
    author= {{World Health Organisation}},
    year  = {2017},
    title = {Vision impairment and blindness, {Fact Sheet N\textsuperscript{o}282}},
    note  = {\url{http://www.who.int/mediacentre/factsheets/fs282/fr/}, 
             Last accessed on 2017-11-30},
}
\end{filecontents}

\documentclass{article}
\bibliographystyle{plain}
\usepackage[hyphens,spaces]{url}

\begin{document}
\cite{OMS}
\bibliography{mybib}
\end{document}
1
  • thanks a lot for your response and for all explanation it helps me!
    – Mac.
    Commented Jan 21, 2018 at 19:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .