1

I am using MikTeX Version 2.9. When I am trying to convert the doxygen comments to PDF, the MikTeX couldn't able to download xcolor.sty. I am running MikTeX Package Manager (Admin).exe and specifying the mirror.kku.ac.th, which was live when I verified online from the following URL: https://miktex.org/pkg/repositories

This is how the connection settings are configured

enter image description here

After that it always says couldn't connect to server.

enter image description here

Could someone help me on this, how to download the xcolor.sty. I went ahead and downloaded xcolor package from the following path: https://ctan.org/pkg/xcolor which has a xcolor.zip. But that doesn't contains xcolor.sty file. Can we show this zip package to the update manager?

Altenatively I do not mind to download all the packages (If it is 1 or 2 GB) and use the local path.

  • 1
    Welcome to TeX.SE! Can it be that you mixed proxy server and mirror? A proxy server is a server driven by your institution you usually need to login. Usually it's url is something like proxy.my-domain.de with special port given by your institute. Check box Authenitification if you need to log in. The Mirror is one ftp server containing MiKTe sources ... – Mensch Jan 23 '18 at 1:39
  • Download MikTeX Net Installer then download and install full packages. Another suggestion is to download TeXlive mirror.kku.ac.th/CTAN/systems/texlive/Images/texlive.iso – Say OL Jan 23 '18 at 6:01
  • Proxy setting was wrong as identified by Kurt. One of my colleague has helped me to provide correct proxy setting. – SUDR G Jan 23 '18 at 6:10
1

Can it be that you mixed proxy server and mirror?

A proxy server is a server driven by your institution/university you usually need to login. Usually it's url is something like proxy.my-domain.de with special port given by your institute. Check box Authenitification ... if you need to log in.

The Mirror is one of several ftp server, for example url http://mirror.kku.ac.th, containing MiKTeX sources ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.