0

I have installed apa6 in MiKTeX. When I run the sample code (longsample.tex) provided by Brian Beitzel, the bibliography is not present. The citations in the text are fine.

When I run BibTeX, I get an error message: "BibTeX returned Exit Code(1) indicating that some problems might have occurred during the compilation ..."

Looking at the files generated, I see that the .bbl file is empty.

Has anyone else had this problem, and if so were you able to get it to work?

Thanks for your help.

1
  • 1
    Please add the content of the blg file to the question.
    – Johannes_B
    Commented Jan 24, 2018 at 7:53

2 Answers 2

1

I discovered the problem and thought this answer might help others with the same problem. The LaTeX code is using biblatex and biber to process the .bib file. I am using miktex with winedt. The version of winedt I use has buttons (pdtexify, texify, and so on) which, by default have the executable for compiling bibliographies set to bibtex.exe, so when I used one of these buttons, it generated and error message and resulted in an empty .bbl file. Changing the executable to biber.exe fixed the problem. How to change this option is described here: Biblatex with Biber: Configuring my editor to avoid undefined citations

0

It seems to me that you might be missing the bibliography.bib file where the references are defined.

http://mirror.utexas.edu/ctan/macros/latex/contrib/apa6/samples/bibliography.bib

2
  • This is better suited than a comment, rather than an answer.
    – Johannes_B
    Commented Jan 24, 2018 at 8:01
  • Sorry, I cannot write comments yet in other people's questions. I just thought this information could help. Commented Jan 24, 2018 at 8:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .