0

I am writing a large document in Latex using ST3 + LatexTools on Ubuntu 16.04.

I never had a problem, except that this morning forward sync was no longer working (by forward sync I mean that Evince opens the pdf document at the position I was editing in ST).

I went through the most recent updates to my Ubuntu distribution, the latest changes to my Latex project, and the LatexTools settings, and everything seems fine to me.

Running the command:

python /path/to/LaTeXTools/evince/evince_forward_search /path/to/main.pdf 21 /path/to/source.tex

only results in Evince opening up the first page of the document, instead of the portion corresponding to line 21 of the sub-file source.tex. The command runs without outputting any error.

I would appreciate hints of what to look for, where things could go wrong, etcetera. This is a very large project including lots of packages and using tenths of sub-files, each of which has the

%!TEX root = ../../main.tex

instruction at the top. This had never caused a problem before.

EDIT: python-dbus, python-gobject and python-gi are all correctly installed and up to date on my system.

Any suggestion?

Thanks :)

  • The most common issue is to not have python-dbus and one of python-gobject or python-gi installed. (See the documentation). If those required packages are installed, then it would be helpful to run the command you show from the terminal and see if any errors or exceptions appear. Note you may need to run the command twice if Evince isn't open or doesn't have the right PDF document opened. – ig0774 Jan 24 '18 at 19:52
  • @ig0774, thanks for your answer but I had already tried all of that (now modifying my question). The command runs without errors, and I have all packages installed. It just doesn't sync to the correct position. From time to time I also lose the ability to backward-sync, therefore I believe that there may be problems handling large documents. – elgicse Jan 24 '18 at 20:24
  • you might try upping the sync_wait parameter in the LaTeXTools settings or, if you’re using a Sublime project, in the project settings area. – ig0774 Jan 25 '18 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.