1

I just installed TeXLive 2017 on a new Windows 10 machine. In trying to get LuaLaTeX to process a simple "Hello World" document, I get the following message:

luaotfload | db : Font names database not found, generating new one.
luaotfload | db : This can take several minutes; please be patient.
luaotfload | db : Failed to save database to disk: nil(save: C:/texlive/2017/tex
mf-var/luatex-cache/generic/fonts/otl/lmroman10-regular.lua)(save: C:/texlive/20
17/texmf-var/luatex-cache/generic/fonts/otl/lmroman10-regular.luc))

The output window also displays

lualatex> luaotfload | db : Index file not writeable
lualatex> luaotfload | db : Failed to write to C:/texlive/2017/texmf-var/luatex-cache/generic/names/luaotfload-names.lua.
lualatex> luaotfload | db : Failed to write to C:/texlive/2017/texmf-var/luatex-cache/generic/names/luaotfload-names.luc.

This is the version of LuaLaTeX that I'm running:

This is LuaTeX, Version 1.0.4 (TeX Live 2017/W32TeX)  (format=lualatex 2018.1.23)  24 JAN 2018 10:02
restricted system commands enabled.

I've given myself "Full control" of the C:/texlive directory (Read, Write, Modify, etc.).

Is there anything I can do to keep LuaLaTeX from generating a new database each run?

  • Review the permissions, and ensure that "full control" applies to the system, yourself as administrator, and possible yourself as ordinary user. If you've already done that... I have no other suggestion. My own Windows 10 partition (migrated from 8) has texlive2017 installed in portable fashion, in my home directory. No problems. – user139954 Jan 24 '18 at 16:03
  • Do you have some protection software which could interfere? Can you copy/create a file in this directory? – Ulrike Fischer Jan 26 '18 at 10:43
  • @RobtAll I thought I had reviewed the permissions properly, but I assumed that permissions would be granted to subdirectories. There is an option to extend them, but that generated Windows errors. So I granted permissions to that specific directory and all works fine. – GregH Jan 26 '18 at 16:20
1

My problem was due to a Windows 10 Permissions issue. While I actively gave myself and all users "Full Control" to the C:/texlive directory, it turns out that those permissions were not automatically extended to subdirectories. I had to specifically give "Full Control" to the C:/texlive/2017/texmf-var/luatex-cache directory.

On the first run, lualatex was able to write to the directory it wanted and now the database is created.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.