1

Formatting the following code shows that endnotes in the tufte-book class have a wider text width than the main body of a document. I would like to avoid this.

\documentclass[]{tufte-book}
\usepackage{lipsum}
\usepackage{endnotes}
\begin{document}
\lipsum[1] place end note here.\endnote{\lipsum[1]}
\theendnotes
\end{document} 
  • It gets better if you use real text in a language that can be hyphenated, instead of Lorem ipsum. I see no big deal with a real-world piece of text. – Joseph Jan 28 '18 at 23:46
  • I noticed the problem when formatting an actual document. – Tom Price Jan 29 '18 at 0:06
  • I see what you art talking about. The problem does go away when using real text. I used the tufte-book class in my original document. The problem persists when I use that class. This class formats footnotes in the margin. In my document, the main text of an endnote clashes with footnotes it may contain. – Tom Price Jan 29 '18 at 0:20
  • To get hyphenation of lorem ipsum text just load \usepackage[main=latin]{babel}. – Andrew Swann Jan 29 '18 at 8:20
2
+50

The endnotes package sets the endnotes with \rightskip=0pt, which gives no room for flexibility at the end of the line. If you add the draft option to the class you will see a black box at the end of nearly every line in the in end notes, indicating the lines are overfull. We can correct this by changing \enoteformat which is originally

\def\enoteformat{\rightskip\z@ \leftskip\z@ \parindent=1.8em
  \leavevmode\llap{\makeenmark}}

and use the \rightskip amount of the tufte ragged right:

\def\enoteformat{\rightskip=\RaggedRightRightskip\leftskip=0pt \parindent=1.8em
  \leavevmode\llap{\makeenmark}}

To get best results enable hyphenation patterns for the language used:

Sample output

\documentclass{tufte-book}

\usepackage[main=latin]{babel}
\usepackage{lipsum}

\usepackage{endnotes}
\def\enoteformat{\rightskip=\RaggedRightRightskip\leftskip=0pt \parindent=1.8em
  \leavevmode\llap{\makeenmark}}

\begin{document}

\lipsum[1] place end note here.\endnote{\lipsum[1]}

\theendnotes
\end{document}

Without this adjustment and with the draft option provided the output is

Sample output

By default \RaggedRightRightskip is 0pt plus 0.08\hsize. You might want a smaller value in the endnotes where the font size is reduced. One choice would be

\rightskip=0pt plus 0.04\hsize

giving

Extra sample

\def\enoteformat{\rightskip=0pt plus 0.04\hsize\leftskip=0pt \parindent=1.8em
  \leavevmode\llap{\makeenmark}}
  • No microtype package? – Keks Dose Jan 29 '18 at 11:29
  • @KeksDose The tufte class already loads microtype. – Andrew Swann Jan 29 '18 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.