3

I am using TexMaker in High Sierra MacOS with mactex and TexLive installed and apparently updated. When I try to compile, I have the message that the versions of Biblatex (3.10) and Biber (2.7) are not compatible (I need Biber 2.10 according to the compatibility matrix).

I have tried updating Biber but it seems imposible since TexLive says that my Biber version is the last one and also that self updates are not available. I tried downloading Biber 2.10 from the sourceforge.net page but I can't install it manually. Yesterday I past all the day with this problem at in the end I decided to erase all the packages, reinstall mactex, texlive and all the packages and the error message is still there.

I know this subject seems replicate (and maybe it is) but I think I read all the concerning questions and answers and either they are not referring to same problem or I am not able to apply them to my problem.

I am sorry if this question is already answered and it's just me that can't solve to with the tools that I already have, but I would appreciate any help you could give.

This is the error message:

INFO - This is Biber 2.7 INFO - Logfile is 'main.blg' INFO - Reading 'main.bcf' ERROR - Error: Found biblatex control file version 3.4, expected version 3.3. This means that your biber (2.7) and biblatex (3.10) versions are incompatible. See compat matrix in biblatex or biber PDF documentation. INFO - ERRORS: 1

and the code is:

\documentclass[12pt]{article}
\usepackage[style=numeric,sorting=nyt,sortcites=true,autopunct=true,
autolang=hyphen,bibencoding=utf8,hyperref=true,abbreviate=false,
backref=true,backend=biber]{biblatex}
\addbibresource{bibliography.bib}

\begin{document}

[Here goes the text that I am ignoring right now]

\printbibliography
\end{document}

I would like to solve it without downgrading the bib latex version if posible.

Thank you very much in advance.

20
  • When you say 'mactex and TexLive installed', do you mean that you have two TeX systems installed? In that case versions conflicts are quite likely. Make sure you have only one TeX distribution installed and that that one is up to date.
    – moewe
    Commented Jan 25, 2018 at 9:12
  • What do you get if you type which -a biber/type -a biber in the command line? Do you get several lines of output? What do you get from kpsewhich -a biblatex.sty?
    – moewe
    Commented Jan 25, 2018 at 9:28
  • @moewe I have: /Library/TeX/texbin/biber for which -a biber; biber is /Library/TeX/texbin/biber for type -a biber and nothing for the last line kpsewhich -a biblatex.sty
    – Carmen
    Commented Jan 25, 2018 at 10:20
  • OK, so there seems to be only one Biber. What does biber --version give?
    – moewe
    Commented Jan 25, 2018 at 10:24
  • 1
    Oh My God thank you soooo much. I don't know how to give you the positive review. It was a painful job the one that you did, I am really grateful that it worked. I think I am going to uninstall Tex with MacPorts to avoid duplicities something similar (wahtever you recommend). Thank you a million times
    – Carmen
    Commented Jan 25, 2018 at 17:56

1 Answer 1

1

Open "MikTex Package Manager" and the "MikTex Package Manager (Admin)": Update in both the BibLatex and Biber Packages

Open "MiKTex Options" and "MiKTex Options (Admin): "Refresh FNDB" and "Update Formats" in both

Try to compile again. It should work now.

3
  • 1
    If there is one thing we can say does not help it is running MikTeX's update manager. The OP uses Mac OS X and states " mactex and TexLive installed". While MikTeX is experimentally available on Mac (see miktex.org/howto/install-miktex-mac) I don't think a lot of people use it already.
    – moewe
    Commented Jan 25, 2018 at 16:07
  • 1
    Using the Tex Live utility I reinstalled both biber and biblatex but the problem still remains. Thank you anyways.
    – Carmen
    Commented Jan 25, 2018 at 16:17
  • 2
    I'am facing same problem both in MikTeX and TL: ERROR - Error: Found biblatex control file version 3.3, expected version 3.4. This means that your biber (2.10) and biblatex (3.7) versions are incompatible. Commented Feb 7, 2018 at 7:12

Not the answer you're looking for? Browse other questions tagged .