1

I'm using the document class scrartcl and want to have an index. This worked fine in the previous years using this source:

\documentclass{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage{mathpazo}
\usepackage[scaled=0.95]{helvet}
\usepackage{courier}
\usepackage{makeidx}
\usepackage{showidx}


\makeindex

\begin{document}

\section{Text}
Here is a Term\index{Term}.

\printindex

\end{document}                                    

However, recently I got the error:

(./index.ind [1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}]

! Class scrartcl Error: undefined old font command `\bf'.

See the scrartcl class documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.2 {\bf
         B}\nopagebreak%
? ^C! Interruption.
\GenericError  ...                                
                                                  \endgroup 
l.2 {\bf
         B}\nopagebreak%

I know that declare the missing command fix the error:

\DeclareOldFontCommand{\bf}{\normalfont\bfseries}{\mathbf}

Obviously I'm using some outdated way to generate an index, so my question is how to generate an index within KOMA script class without declare old deprecated commands?

  • Strangely enough, if I correct the missing ` before documentclass` and run pdflatex/makeindex/pdflatex on your example document above, I don't get the error message you reported. There must be something you don't show. Neither makeidx nor scrartcl uses \bf any longer – user31729 Jan 27 '18 at 6:48
  • Side note: You have some answers to your questions, but accepted none. Please consider to accept them in order to show your appreciation of the help provided by TeX.SE users – user31729 Jan 27 '18 at 6:55
  • 1
    you are using a non standard makeindex style? – David Carlisle Jan 27 '18 at 8:44
1

Thank you Christian Hupfer and David Carlisle!

Indeed, the Makefile called makeindex with the -s parameter and referred to an style file which was unknown for me. Within the style file the \bf command was used. After replacing that, it works as expected. Thank you very much for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.