0

I downloaded the most current zip file for the 'bidi' package from CTAN and attempted to build it.

First I ran sudo latex bidi.ins which ran with no errors. Next, I ran this: sudo latex bidi.dtx

which throws this error:

! Fatal fontspec error: "cannot-use-pdftex"

and indicates either XeLaTeX or LuaTeX must be used instead to build it. So I tried this:

sudo xelatex bidi.dtx

which throws this error:

! fontspec error: "font-not-found"
! 
! The font "Minion Pro" cannot be found.

Seems odd this package should look for a specific font.

I tried installing the bidi package through a texlive package available through the Debian (XeTeX, Version 3.14159265-2.6-0.99996 TeX Live 2016/Debian for stretch and jessie) package installer, but that version of bidi throws errors like this one when run with XeLaTeX:

! LaTeX Error: Command \XeTeX already defined.

Can anyone point me to a version of bidi that actually works?

Thanks

bumped to the homepage by Community 23 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • 5
    Why don't you install the package using the package manager? You are failing to compile the documentation of the bidi package. If you have created the sty file, the package is available. – Johannes_B Jan 28 '18 at 8:46
  • As I mentioned, I tried that through the Debian package installer. That version of bidi, quoted above, throws errors. – hilbert Jan 28 '18 at 9:00
  • 2
    I didn't read that far.I also don't recommend the Linux versions of TeX Live, rather the vanilla version as distributed by the TeX user group. – Johannes_B Jan 28 '18 at 9:01
  • 1
    @hilbert: Apparently Debian is still providing outdated packages etc. I recommend to use the TeXLive net installer, which allows for updating the whole TeX distribution at any time (apart from the period where TL is frozen from April to June) – user31729 Jan 28 '18 at 9:01
  • Perhaps, which is why I tried installing the most recent version of bidi from from CTAN, which is presumably the same one I'm going to get from the TexLive net installer. But, as I mentioned, that version doesn't build cleanly on my system. The bidi.sty file that does get built gives the same errors as what appear with the Debian package. – hilbert Jan 28 '18 at 9:20
0

The core issue was this command:

\usepackage{xltxtra}

causes errors to be given when using TeX Live 2016 packages in conjunction with polyglossia and bidirectional languages. I've only seen this in a Debian-based installation, but it may appear elsewhere. Prior to the 2016 build, xltxtra didn't cause a problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.