I've just installed TL2011 on Windows 7 and updated it from the net. The installation produced no errors and everything is fine - but now xelatex (and not pdflatex nor lualatex) ends every invocation with

** WARNING ** Couldn't open font map file "kanjix.map".

I already did a mktexlsr and an updmap --syncwithtrees, but to no avail; there is still no kanjix.map and xetex wants it.

How do I get rid of this warning either by creating the file or removing it from updmap.cfg?

EDIT: My updmap.cfg has these lines:

KanjiMap ptex-@kanjiEmbed@.map
KanjiMap otf-@kanjiEmbed@.map
KanjiMap morisawa.map
KanjiMap otf-cktx.map

  • 1
    My updmap.cfg file has four entries labeled KanjiMap; does yours also? – egreg Jan 16 '12 at 14:29
  • @egreg: Yes, see above. – Martin Schröder Jan 16 '12 at 15:01
  • Do you use updmap or updmap-sys? In general the latter is recommended – egreg Jan 16 '12 at 15:07
  • @egreg: updmap. I just tried updmap-sys - no change. – Martin Schröder Jan 16 '12 at 15:20
  • You should first of all remove all files created by updmap, you should find them in updmap.log in the .texlive2011 directory (or where they are created on Windows). What's the output of kpsewhich updmap.cfg? – egreg Jan 16 '12 at 15:25

Using updmap instead of updmap-sys results usually in head scratching or nightmares.

If one has administrative privileges, he/she should always rely on updmap-sys; updmap can be used by users that want to add personal map files that they aren't allowed to add system-wide, but must be run frequently to avoid that changes in the distribution may have adverse effects on the personal map tree.

This said, it happens sometimes that updmap(-sys) created files get out of synch. The best thing to try is

updmap-sys --syncwithtrees

(assuming administrator privileges). This usually solves the issues.

A cause of errors in producing the correct map files is that during the process launched by tlmgr, some input map file can't be found. Trace of this can be found in the tlmgr log, in TEXMFSYSVAR/web2c/tlmgr.log, where TEXMFSYSVAR usually points to texlive/2011/texmf-var.

  • The problem was caused by a borked installation during which updmap failed. After that I never tried updmap(-sys) without arguments again. When I did, it fixed the problem. – Martin Schröder Jan 16 '12 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.