1

How can I set up documents in Chalkduster:

\usepackage[no-math]{fontspec}
\setmainfont[Mapping=tex-text]{Chalkduster}
\usepackage[defaultmathsizes]{mathastext}

Thanks in advance.

1

XeLaTeX is a great solution to all font issues. The code you have should work:

\documentclass{standalone}
\usepackage[no-math]{fontspec}
\setmainfont[Mapping=tex-text]{Chalkduster} 
\usepackage[defaultmathsizes]{mathastext}
\begin{document}
I am a poor imitation of a chalkboard
\end{document}

Make sure you typeset with XeLaTeX, not LaTeX (there are usually such options in your editor). You also need the Chalkduster font installed on your machine and need to use the correct name (this should show up when using a font explorer or similar). Here's the result:

enter image description here

Here is a handy guide for using custom fonts.

  • 2
    Mapping=tex-text should be Ligatures=TeX, but it can be omitted, because the option is set by default for the main font. – egreg Jan 29 '18 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.