0

I am using sharelatex and pdfLatex as my compiler.

When I change my documentclass to article the nomenclature shows but if I have report as documentclass I don't see the nomenclature, example code below

\documentclass{report}
\usepackage[intoc]{nomencl}
\usepackage{etoolbox}

\makenomenclature

\begin{document}

\tableofcontents

\clearpage

\section*{Main equations}
\begin{equation}
a=\frac{N}{A}
\end{equation}%

\nomenclature{$a$}{The number of angels per unit area}%
\nomenclature{$N$}{The number of angels per needle point}%
\nomenclature{$A$}{The area of the needle point}%
The equation $\sigma = m a$%
\nomenclature{$\sigma$}{The total mass of angels per unit area}%
\nomenclature{$m$}{The mass of one angel}
follows easily.
\printnomenclature

\end{document}

Any help appreciated!

  • Works fine with both here (on ShareLaTeX). – Torbjørn T. Jan 29 '18 at 17:50
  • Of course, with report the nomenclature heading is a \chapter, so it starts on the next page. – Torbjørn T. Jan 29 '18 at 17:50
  • Hmm okey that is weird. Could you share your code? Or some setting I am missing? Doesn't work when I try with a local compiler either – user1455613 Jan 29 '18 at 19:34
  • You could try with a new project, though I don't know if it would make a difference. I just made sharelatex.com/read/sntnqztrpfpp and hit the compile button once. As you can see, the nomenclature is there on page 3. – Torbjørn T. Jan 29 '18 at 19:39
  • I see, there must be some fishy problem in with imported packages or something. Thanks I will look further! – user1455613 Jan 29 '18 at 19:59
1

So I solved the problem.

In Sharelatex I had my main.tex file within a folder. Remove this folder (i.e. have main.tex in the root) fixed the problem.

I guess it has something to do with tex having problem to find the .nlo file or something similar.

Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.