3

I am using this journal template and have a problem when doing \maketitle after loading the siunitx package.

\documentclass[extra,mreferee]{gji}
\bibliographystyle{gji}

\let\tablenum\relax    
\usepackage{siunitx}

\begin{document}

\title{Some Fancy Research}
\maketitle

\end{document}

I get an error with this log:

! Missing # inserted in alignment preamble.
<to be read again> 
               \cr 
l.10 \maketitle

There should be exactly one # between &'s, when an
\halign or \valign is being set up. In this case you had
none, so I've put one in; maybe that will work.

Without loading siunitx everything works fine. How might I be able to fix this?

EDIT: I just found out that this error is also caused by the tabu package. Not sure how this can help me though...

5

The issue isn't siunitx or tabu, it's the standard array package (part of the core LaTeX distribution): siunitx loads array. That counts more or less as 'fundamentally defective' in terms of the behaviour of the class. You'll have to use is 'as is' (load no other packages) if that is what is required to submit to this journal.

  • Thank you! I was hoping I could use these packages but looks like I will have to make do without them then.. – ye-ti-800 Jan 30 '18 at 14:56
4

If you really must ypu can re-instate the original tabular just for the \maketitle settings.

\documentclass[extra,mreferee]{gji}

\makeatletter
\let\zz@tabular\@tabular
\let\zzendtabular\endtabular
\let\zz@xtabularcr\@xtabularcr
\let\zz@tabclassz\@tabclassz
\let\zz@tabclassiv \@tabclassiv 
\let\zz@tabarray\@tabarray
\makeatother

\bibliographystyle{gji}

\let\tablenum\relax    
\usepackage{siunitx}

\begin{document}

\title{Some Fancy Research}

{\makeatletter
\let\@tabular\zz@tabular
\let\endtabular\zzendtabular
\let\@xtabularcr\zz@xtabularcr
\let\@tabclassz\zz@tabclassz
\let\@tabclassiv \zz@tabclassiv 
\let\@tabarray\zz@tabarray
\maketitle
}


\end{document}

enter image description here

  • thank you, great advice! Would the same be possible for siunitx? – ye-ti-800 Jan 30 '18 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.