1

I'm writing a paper using Achemso, in TexMaker. Originally I couldn't get my paper to compile with the citations, they just showed as question marks. Eventually after many tweaks, I got it working, and the now previous version of my paper (version 2) compiled completely, including bibliography and compressed citation numbers.

After some editing, version 3 now will not compile, and gives the error:

INFO - This is Biber 2.6 INFO - Logfile is 'MYFILENAME.blg'

ERROR - Cannot find control file 'MYFILENAME.bcf'! - did you pass the "backend=biber" option to BibLaTeX? INFO - ERRORS: 1

I've tried looking for this complaint in stackexchange, and tried inserting the command \usepackage[backend=biber]{biblatex}, but that made a huge list of errors that mostly refer to various bibliography related commands having already been defined elsewhere. I believe that is in the achemso style package.

Any suggestions of what to try would be very welcome, I have a deadline approaching, and it's been a long time since I've been this helplessly stumped on a problem. Usually a few stackexchange seaches finds what I need, but this is maddening.

My TexMaker is configured as seen in the attached image, and test code that is my paper with all the info removed, and an example cite command is included. If I'm missing anything necessary please let me know.

Test Code:

\documentclass[journal=jacsat,manuscript=article]{achemso}
\usepackage[version=3]{mhchem} % Formula subscripts using \ce{}
\usepackage[T1]{fontenc}       % Use modern font encodings  
\usepackage{amsmath,amssymb,amstext} 
\usepackage{textgreek}
%\usepackage{biblatex}
%\usepackage[backend=biber]{biblatex}
\usepackage{gensymb} 
\usepackage[font=normal, labelfont=bf]{caption} 
\usepackage{placeins}
\usepackage{ctable}
\usepackage{siunitx}
\usepackage{flafter}
\newcommand*\mycommand[1]{\texttt{\emph{#1}}}

\title{Title}
\author{A1}
\affiliation{Aff1}
\altaffiliation{Corresponding Author}
\email{email}
\author{A2}
\affiliation{Aff1}
\author{A3}
\affiliation{Aff2}
\phone{phone number}
\title[Title]
  {Title}
\keywords{keywords}
\begin{document}
\begin{abstract}
Test
\end{abstract}

\section{Introduction}
This is a test file.  The next citation has 4 references in it \cite{citation1, citation 2, citation 3, citation 4}.  

%\bibliographystyle{achemso}    % this is left over from previous suggestions for this ongoing problem
\mciteErrorOnUnknownfalse       % this is included due to previous suggestions for this ongoing problem

\bibliography{MyBibliographyDatabasev003} %no file format, is in same dir.

\begin{suppinfo}
The following files are available free of charge.
\begin{itemize}
  \item SuppInfo.PDF: Supporting information for this paper.
\end{itemize}
\end{suppinfo}
\end{document}

Configuration screenshot: enter image description here

1

The achemso class sets a fixed 'classical' (BibTeX) bibliography style. It cannot be used with biblatex (at least not in a supported way).

If you add biblatex with backend=biber, a .bcf file will be created. Some editors may pick this up and automatically run Biber rather than BibTeX. That will lead to 'unexpected' outcomes, including Biber errors. Remove the .bcf (and loading of biblatex) to fix this.

  • This worked! And after fixing some citation database errors that this fix uncovered, everything compiled! Thanks so much! – Geoff Feb 1 '18 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.