I would like to cite a webpage. Citations are collected in Mendeley 1.17.13 which has BibTex syncing enabled. The citation is inserted into Lyx 2.2.3. with citation style natbib author-year, bibliography style plain, bibliography generator default, BibTex Generated Bibliography style set to apa.

LibreOffice using the Mendeley plug in, produces the right result:

CIF. (2018). What We Do | Climate Investment Funds. Retrieved February 1, 2018, from https://www.climateinvestmentfunds.org/about

Lyx doesn't:

CIF (2018). What We Do | Climate Investment Funds.

How can I add the missing "Retrieved" and "from" fields?

A small Tex file can be found here.

  • If LyX literally uses the apa.bst to implement the APA style, it's a very old and poor approximation of APA. To get proper APA style you need to either us biblatex with [style=apa] or the apacite package with the [natbibapa] option \bibliographystyle{apacite}. Since I don't use LyX I can't help you on how to do that, though.
    – Alan Munn
    Feb 1 '18 at 14:19
  • LyX supports apa6.
    – scottkosty
    Feb 1 '18 at 16:19
  • I have tried apacite, apacitex, apalike and chicago. None of them produce links and date assessed in the biography.
    – Henk
    Feb 1 '18 at 16:19
  • 1
    @scottkosty apa6 is a document class that has nothing to do with bibliographies.
    – Alan Munn
    Feb 1 '18 at 16:37
  • @Henk apacite should do the right thing, I think. Can you make a small sample document and export the TeX and add it to your question?
    – Alan Munn
    Feb 1 '18 at 16:38

Henk, you may try these steps:

  1. In your Mendeley, activate the 'Medium' field for webpage entries in the tool options: (Tools > Options > Document Details)
  2. Then, put the retrieve date and webpage’s url in the medium-field: e.g. Retrieved February 1, 2018, from https://www.climateinvestmentfunds.org/about
  3. Finally, export your Bibtex file and render the document.

Ref: http://www.bar54.de/2013/10/mendeley-webpage-entry-urls-in-bibtex-export/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.