1

I installed texstudio to give it a try.

Before, I used to use TexShop. Since I have installed it, a MWE such as

\documentclass{article}
\usepackage[shortlabels]{enumitem}

\begin{document}
Test
\end{document}

doesn't compile anymore (with TeXShop or texstudio). The error message is

/usr/local/texlive/texmf-local/tex/latex/dblatex/misc/enumitem.sty:488: LaTeX E rror: Unknown option shortlabels' for packageenumitem'

NB: few days ago, I tried to install another software that installed another copy of latex through macports. But I think I uninstalled it, via macports also.

The path above with dblatex makes think of this. I remember during the installation to have seen this name.

Can you help?

closed as off-topic by Troy, Kurt, Phelype Oleinik, user36296, Stefan Pinnow May 13 '18 at 20:05

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Texstudio etc. are just editors that rely on the TeX installation. I don't expect them to change the installation of TeX. It is more likely that the TeX tree was screwed up by the additional installation of a LaTeX copy with macports. – user31729 Feb 4 '18 at 23:02
  • 1
    I am no Mac user, but a clear wiping of the TeX tree and reinstallation should be successful. But try a rehashing of the TeX database – user31729 Feb 4 '18 at 23:06
  • 1
    Using macports to install LaTeX on top of my TeXLive installation. Actually, I did not explicitly install TeX things, but somehow macports screwed up my lualatex directories. @egreg found this out. – marmot Feb 4 '18 at 23:16
  • 1
    @marmot: Your turn ;-) It is apparently the wrong setup caused by macports then and not the installation of the editor – user31729 Feb 4 '18 at 23:16
  • 4
    I'm voting to close this question as solved in comments (faulty installation). – Troy May 13 '18 at 16:42