0

I am new to Latex but I want to write my master's thesis using it. The official requirement for reference style is the one used in Operations Research published by INFORMS. So I found a template of it on ShareLatex and copied the code regarding natbib to my own tex file.

I can't figure out why the reference list isn't printed using the natbib package. Can someone please help? I have already spent four hours googling this and still no answer.

I use TeXStudio and when I run the file, it tells me that there are undefined citations. Basically, none of my citations show in the text. And there's no reference section either.

My tex file looks like this:

\documentclass{report}
\usepackage[utf8]{inputenc}
\usepackage{natbib}
\bibliographystyle{ormsy080}
 \bibpunct[, ]{(}{)}{,}{a}{}{,}%
 \def\bibfont{\small}%
 \def\bibsep{\smallskipamount}%
 \def\bibhang{24pt}%
 \def\newblock{\ }%
 \def\BIBand{and}%}

\begin{document}
\citet{Chenetal2016}
\citep{Fildesetal2009}
\bibliography{AA}

\end{document}

I have a bib file saved in the same folder as my tex file and it's named AA. Here are the two bib entries I was trying to cite.

@Article{Chenetal2016,
  author    = {Daniel L. Chen and Martin Schonger and Chris Wickens},
  title     = {{oTree}{\textemdash}An open-source platform},
  journal   = {Journal of Behavioral and Experimental Finance},
  year      = {2016},
  volume    = {9},
  month     = {mar},
  pages     = {88--97},
  doi       = {10.1016/j.jbef.2015.12.001},
  abstract  = {[B]},
  keywords  = {rank4},
  publisher = {Elsevier {BV}},
}

and

@Article{Fildesetal2009,
  author    = {R. Fildes and P. Goodwin and M. Lawrence and K. Nikolopoulos},
  title     = {Effective forecasting and judgmental adjustments},
  journal   = {International Journal of Forecasting},
  year      = {2009},
  volume    = {25},
  number    = {1},
  month     = {jan},
  pages     = {3--23},
  doi       = {10.1016/j.ijforecast.2008.11.010},
  abstract  = {[A]},
  publisher = {Elsevier {BV}},
}
  • Welcome to TeX.SX! Assuming you have the file ormsy080.bib, you have tom compile pdflatex, then bibtex, then pdflatex twice and it should work. If you are getting ? (?) as output then either: a) you don't have ormsy080.bib or; b) you aren't compiling bibtex. – Phelype Oleinik Feb 5 '18 at 15:09
  • @PhelypeOleinik Thanks for your explanation. I didn't have the ormsy080.bst. But I just downloaded it from sharelatex now. And for compile, the only way I know how to compile so far is to click the green compile button in TexStudio while my .tex file is opened... – Michelle Feb 5 '18 at 15:42
  • @Michelle TeXStudio should automatically run BibTeX, so once you have the ormsy080.bst (sorry, in my first comment I said ormsy080.bib) it should compile correctly. – Phelype Oleinik Feb 5 '18 at 15:45
  • @PhelypeOleinik Thanks a lot! It worked!! Awesome. and I changed \bibliographystyle{ormsy080} into ormsv080 as Kurt suggested! – Michelle Feb 5 '18 at 16:00
  • @Michelle Great! Just a tip for the future: When your bibliography does not appear take a look in the .blg file. It will contain the log generated by bibtex. LaTeX IDEs are surprisingly bad at reading the .blg file. For example, when I compiled your file I got: I couldn't open style file ormsy080.bst ---line 2 of file test.aux : \bibstyle{ormsy080 : } I'm skipping whatever remains of this command. This will help you debug your bibliography. – Phelype Oleinik Feb 5 '18 at 16:06
1

My bibliography now prints out as wanted after I did the following:

  1. download the bst file specified in \bibliographystyle{}
  2. make sure the name of the bst file corresponds to what is inside the \bibliographystyle{}
  3. using TeXStudio, simply click on compile.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.