25

As late as last week my setup for biblatex worked fine. Going back to the same project today not even a minimal file compiles:

\documentclass{article} 

\usepackage{biblatex}
%\addbibresource{biblatex-examples.bib} 

\begin{document}

test%foo\nocite{*}   
%\printbibliography

\end{document}

but breaks off with

/usr/local/texlive/2017/texmf-dist/tex/latex/biblatex/biblatex.sty:3776: LaTeX 
Error: Missing \begin{document}.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.3776   australian,newzealand}
? 
/usr/local/texlive/2017/texmf-dist/tex/latex/biblatex/biblatex.sty:3776: Math f
ormula deleted: Insufficient symbol fonts.
\expandafter ->american|

l.3776   australian,newzealand}

And keeps repeating the last one until

 (That makes 100 errors; please try again.)

when I ignore it.

Files without biblatex work as expected.

Using tlmgr to go my two backup versions of biblatex back in time to 1st Jan I still get the same errors.

Could this be another update from the last week or so that causes this?

If I swich back to TL 16 things work as expected. (For my work I need TL 17 because of packages.)

  • I worked around this issue by reverting back to the previous version of etoolbox. – tucuxi Feb 6 '18 at 22:12
28

This is due to a (faulty) change in etoolbox, or rather an oversight in a change: see https://github.com/josephwright/etoolbox/issues/19. A temporary fix is to patch around the issue:

\documentclass{article}

\usepackage{etoolbox}
\makeatletter
\long\def\etb@listitem#1#2{%
  \expandafter\ifblank\expandafter{\@gobble#2}
    {}
    {\expandafter\etb@listitem@i
     \expandafter{\@secondoftwo#2}{#1}}}
\long\def\etb@listitem@i#1#2{#2{#1}}
\makeatother
\usepackage{biblatex}

An update is on the way to CTAN and will therefore be available within around 48 hours via the usual channels.

  • typical tex.SE-problem: cannot accept perfect answer because of time restrictions ;) – Florian Feb 6 '18 at 10:17
  • I can confirm that the 2.5c update of etoolbox avaible on my CTAN mirror now solves the problem. – Florian Feb 7 '18 at 8:23
  • New version is now in TeXLive! I just updated and problem solved! – tatojo Feb 7 '18 at 14:10
  • Same problem occurs on MiKTeX. I did a clean reinstall today and have updated packages, but the problem persists. I presume MiKTeX updates are lagging behind CTAN. Anyway, the workaround is great. Many thanks. – LimnoLeon Feb 8 '18 at 2:26
  • 1
    @LimnoLeon As of this morning the 7. Feb. update ships etoolbox v2.5c which fixes this issue (apparently there is still another issue github.com/josephwright/etoolbox/issues/20, but that does not affect biblatex). – moewe Feb 8 '18 at 7:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.