3

I'm trying to use the ebproof package with the following MWE:

\documentclass[12pt, letterpaper]{report}
\usepackage[utf8]{inputenc}
\usepackage{ebproof}

\begin{document}

\begin{prooftree}
    \hypo{ x {:} \sigma \in \Gamma }
    \infer1[var]{ \Gamma \vdash x {:} \sigma}
\end{prooftree}

\end{document}

(taken from this question)

However when I try to compile it to a pdf I get the following error:

$ pdflatex test.tex 
This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015/Debian) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
(./test.tex
LaTeX2e <2016/02/01>
Babel <3.9q> and hyphenation patterns for 81 language(s) loaded.
(/usr/share/texlive/texmf-dist/tex/latex/base/report.cls
Document Class: report 2014/09/29 v1.4h Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size12.clo))
(/usr/share/texlive/texmf-dist/tex/latex/base/inputenc.sty
(/usr/share/texlive/texmf-dist/tex/latex/base/utf8.def
(/usr/share/texlive/texmf-dist/tex/latex/base/t1enc.dfu)
(/usr/share/texlive/texmf-dist/tex/latex/base/ot1enc.dfu)
(/usr/share/texlive/texmf-dist/tex/latex/base/omsenc.dfu)))
(/usr/share/texlive/texmf-dist/tex/latex/ebproof/ebproof.sty
(/usr/share/texlive/texmf-dist/tex/latex/pgf/utilities/pgfkeys.sty
(/usr/share/texlive/texmf-dist/tex/generic/pgf/utilities/pgfkeys.code.tex
(/usr/share/texlive/texmf-dist/tex/generic/pgf/utilities/pgfkeysfiltered.code.t
ex)))) (./test.aux)
! Undefined control sequence.
<recently read> \hypo 

l.8     \hypo
             { x {:} \sigma \in \Gamma }
? q
OK, entering \batchmode⏎

I have no idea what I'm doing wrong :/

I'm using TeX Live on Linux Mint 18.1 and it is updated to the latest version through Mint's package manager.

  • Your code runs through without problems on TeXLive2017 on MacOS. Your output shows TeX Live 2015/Debian. Are you sure that this is the latest version? – marmot Feb 6 '18 at 18:42
  • I guess what I meant to say was "the latest version of TeXLive that comes with Mint 18.1", which admittedly might not be recent enough. – angrydust Feb 6 '18 at 18:59
  • This does seem like a strange error though, since the ebproof.sty file does exist on my computer, and it does contain the definition for \hypo. – angrydust Feb 6 '18 at 19:07
  • 1
    Well, you might want to look through your ebproof.sty file and check if \hypo is defined there and/or use texdoc ebproof in order to see which commands are provided by your version. – marmot Feb 6 '18 at 19:10
  • Turns out the commands are uppercase in ebproof versions lower than 2.0. Thanks for your help! (If you want to post that as an answer I will accept it, otherwise I'll accept my answer in a couple of days.) – angrydust Feb 6 '18 at 19:21
4

Version 1.1 of the ebproof package (March 13, 2015) uses \Hypo and \Infer rather than \hypo and \infer. Thanks to marmot for suggesting that I used texdoc ebproof.

As a workaround I've added this to my preamble:

\newcommand\hypo{\Hypo}
\newcommand\infer{\Infer}

(This will make it easy to update to ebproof v2.0 or TeXLive 2017 in the future without breaking my LaTeX document.)

Alternatively installing TeXLive 2017 from a PPA would fix the issue via version 2.0 of ebproof which uses lowercase commands. (I did not actually try this approach myself).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.