2

I try to get my files indented automatically with arara, latexindent and texmaker. I have the TexLive Distribution, so both programs should be installed correctly (or am I wrong?). At least when I start them over commandline, I get response:

  __ _ _ __ __ _ _ __ __ _
 / _` | '__/ _` | '__/ _` |
| (_| | | | (_| | | | (_| |
 \__,_|_|  \__,_|_|  \__,_|

arara 3.0a - The cool TeX automation tool
Copyright (c) 2012, Paulo Roberto Massa Cereda
All rights reserved.

... and ...

latexindent.pl version 3.3, 2017-08-21
usage: latexindent.pl [options] [file][.tex|.sty|.cls|.bib|...]

... So far so good. With my own command in Texmaker (arara %.tex) I just don't get it to run properly. When I tested %arara: pdflatex, it worked fine, but %arara: indent: {overwrite:yes, trace:yes} always gives me the following error message:

C:\texlive\2017\bin\win32\runscript.tlu:711: command failed with exit code 1: java.exe -jar c:\texlive\2017\texmf-dist\scripts\arara\arara.jar indent_test.tex

Since the pdflatex example worked, the problem should be latexindent. But what exactly is the problem? Do I have to install a special pearl environment?

Thanks in advance! Frieder

closed as unclear what you're asking by cmhughes, TeXnician, Kurt, Andrew Swann, Stefan Pinnow Mar 30 '18 at 10:45

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you got the latest version of indent.yaml from github.com/cereda/arara/tree/master/rules – cmhughes Feb 7 '18 at 7:39
  • Does latexindent.exe work from the command line? E.g. latexindent.exe myfile.tex – cmhughes Feb 7 '18 at 7:41
  • @cmhughes yes, I put the file in the following directory: C:\texlive\2017\texmf-dist\scripts\arara\rules – Wulle Feb 7 '18 at 7:44
  • @cmhughes it actually worked over command line! So there should be a way to get it work properly in texmaker – Wulle Feb 7 '18 at 7:55
  • @cmhughes: the rule from GitHub won't work because it's for version 4.0. Gimme some time and I will try to rewrite it for version 3.0, if possible. That might be the culprit. – Paulo Cereda Feb 7 '18 at 11:26