0

I have tried sudo apt-get install texmaker, I have tried the software center, I have tried downloading the latest version from their website and everything results in the exact same behavior, I try to run texmaker and then it disappears from the toolbar.

I am not sure if this is a new thing or not because nothing suggested from other sources online has worked for me.

  • (1) welcome, (2) since other Ubuntu users does not seem to have any problems, could you a bit (or a lot) more specific. Have you tried running it from a terminal? Just run the command texmaker. Note, run it in a terminal, not as run command (that is via the F keys or something, I never use run command ). Running it from a terminal may reveal a lot more details as to why it fails – daleif Feb 7 '18 at 8:06
  • I get this error: texmaker: symbol lookup error: texmaker: undefined symbol: synctex_next_result – Jonathan Feb 7 '18 at 8:33
  • Did you google the error? I got this hit: tex.stackexchange.com/q/392278/3929 – daleif Feb 7 '18 at 9:23
  • I apologize for the late comment, but I am not sure exactly how to resolve this issue. In that question, no information is given as to what version of texlive I need to install and how to remove texlive from my computer without causing any conflicts. I installed texworks and it works fine, I do not understand why I need to install an older version to make texmaker work. Why hasn't texmaker updated itself, or is there some version out there already that I am missing out? – Jonathan Feb 9 '18 at 5:29
  • I don't use it so cannot help there. It sounds quite strange that it would not work of the bat. But I have had several windows users who went back to version 4.5 because they did not like version 5 (either the look, or because the viewer crashed oncertain docs). Have you given texstudio a try (it has the same base idea as texmaker but more features) – daleif Feb 9 '18 at 7:07
1

Your libsynctex1 package is too recent thus texmaker does not recognize it. Install aptitude then lookup the version then downgrade it as below:

sudo apt install aptitude
aptitude versions libsynctex1
sudo aptitude install libsynctex1=2015.20160222.37495-1 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.