0

I am in the process of transitioning from using Texpad and BibDesk on Mac OS to trying to find something that works for me on Windows.

When I try to compile on e.g. TexMaker or TexStudio using the latest TexLive distribution (and JabRef as my bibliography manager for .bib file if that's relevant), I get the following errors:

enter image description here

It seems there's a problem with XeTeX. The editor does compile a PDF though. The PDF is fine except that the citations have been replaced by question marks. I'm not sure if this is related to the XeTeX issue or is a separate problem. Total amateur with LaTeX would really, really value any input.

Edit in repsonse to a request for a minimal working example, I tried just creating a simple document and got an error message:

enter image description here

Is this because my distribution is in the wrong path? Apologies for being so terrible at this and thanks in advance for any suggestions

Edit 2 This is the original error message:

enter image description here

As you can see, AFAIK, I am running it with Lualatex. Problem replicates with Xelatex. TexMaker doesn't appear to have Xetex (unlike Texpad).

  • Welcome to TeX.SX! Can you somehow isolate the problem and then post a compilable minimal working example (which may well throw errors of course)? This way, others will be able to help you. With just this screenshot we can only guess the cause of your problem. – Jasper Habicht Feb 7 '18 at 18:36
  • The error messages of texmaker don't show everything. Better look in the log-file. – Ulrike Fischer Feb 7 '18 at 18:43
  • the errors show that you have used pdflatex instead of xelatex – David Carlisle Feb 7 '18 at 18:44
  • @UlrikeFischer oops :-) ^^^ – David Carlisle Feb 7 '18 at 18:44
  • @DavidCarlisle Oh. I didn't look at the last one ;-) – Ulrike Fischer Feb 7 '18 at 18:45
1

Your document requires xelatex, but (as shown in the last error that you show) you are using pdflatex. You should be able to switch to xelatex in the editor menus.

  • thank you so much, and thanks to others too. I tried constructing a minimal example per @Jasper Habicht. But when I try to compile (LaTeX, PDFLaTeX, or Xelatex) I get an error saying "log file not found". Is this because my distribution is not in the correct path? (I hope you guys have patience to help out a noob) – nathan glass Feb 7 '18 at 19:03
  • @nathanglass the log file not found usually means tex did not run at all (often because it has not been installed, if you just install the editor) but the original error image that you showed clearly showed tex error messages from pdftex, so there seems to be a contradiction, what happens if you run the original document, do you get the tex errors or "no log" ? – David Carlisle Feb 7 '18 at 19:40
  • Thank you once again. Please see the 2nd edit to the original question. When I run the original document, it compiles a PDF but I get the tex error messages. – nathan glass Feb 7 '18 at 20:23
  • Hi @David Carlise, would you be amenable to chatting about this? I am happy to use whatever editor you recommend (if you're not TexMaker). I don't have enough reputation to use the chat room unfortunately... – nathan glass Feb 8 '18 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.